I-DISA

Members
  • Posts

    25
  • Joined

  • Last visited

core_pfieldgroups_99

  • Nome
    Gian Maria

I-DISA's Achievements

Member

Member (2/3)

10

Reputation

  1. Ciao, Ho un MacBook Nero del maggio 2007. Installo il sistema operativo Mac OS X 10.4.11 Tiger. L'altro giorno attacco le Casse Audio esterne per sentirmi un po' di musica in qualità migliore. Poi le stacco, ed improvvisamente non si sente più nulla. Se faccio per alzare/abbassare il volume mi compare il logo del volume fisso al massimo con un divieto in basso. L'unico suono che sento è, il jingle in avvio del Mac. Come ripristino l'audio normale del mio Mac? Thanks!
  2. OK, quello lo avevo visto. Ma io mi riferivo all'opzione per avere le cartelle scritte in un colore, i file in un altro, gli eseguobili in un altro anocra. Quella dove la pesco?
  3. Ho un programma fortran. Il programma conta di 2 sottocartelle con i file .f, una sottocartella con delle common, ed una sottocartella con l'eseguibile ed il file dati. Come fare per creare il makefile per far girare il programma con il g77 che ho installato nel mio computer? thanks!
  4. Ciao, come faccio a configurare il mio terminal bash, in modo che esso presenti le liste dei file e delle cartelle con i colori? Io al momento ho sfondo bianco e tutte le scritte nere, come cambiare? Thanks!
  5. Tralaltro il programma l'hoscaricato qui: http://www.xm1math.net/texmaker/index.html Sembrerebbe bastare...
  6. "Error : could not start the command" Ciò me lo scrive quando mando il comando pdflatex.
  7. Non credo , ma penso che Texmaker abbia anche i compilatori latex. Cmq se digito latex mi appaiono un po' di cose figli di programmi che ho scricato quali: Lyx Latexit iRexmac2
  8. Ho difficoltà a creare il pdf con Latex mediante Texmaker. Mi sembra di aver settato bene le preferenze di configurazione, come da istruzioni. Istruzioni e file vengono da qui http://www.xm1math.net/texmaker/index.html . Il messaggio che mi viene scritto quando creo il pdf (dopo aver gia salvato il file.tex) è il seguente: Error : could not start the command Dove sbaglio? I passaggi da fare sono pochissimi; sembrerebbe facile, invece...
  9. Ho un porgramma fortran che conta di una cartella principale con una serie di sottocartelle ove ci sono una trentina di file.f, l'eseguibile, il file make, i file dati ecc ecc. Solitamente compilando il programma con il comando "make" e poi lanciando l'eseguibile (./nome_eseguibile), il programma dovrebbe iniziare a girare. Tuttavia sul mio mac non funge. Nel senso: quando do il comando make mi esce fuori quest scritta: REBUILDING PROGRAM g77 -p -o ../RUN/aermod_ff_fw main.o geo_rot.o mode.o coef.o tdsl_ff.o struct_hb.o strcoef.o -L. -lbem -lm /usr/bin/ld: main.o bad magic number (not a Mach-O file) /usr/bin/ld: geo_rot.o bad magic number (not a Mach-O file) /usr/bin/ld: mode.o bad magic number (not a Mach-O file) /usr/bin/ld: coef.o bad magic number (not a Mach-O file) /usr/bin/ld: struct_hb.o bad magic number (not a Mach-O file) /usr/bin/ld: strcoef.o bad magic number (not a Mach-O file) /usr/bin/ld: archive: ./libbem.a has no table of contents, add one with ranlib(1) (can't load from it) collect2: ld returned 1 exit status make[1]: *** [../RUN/aermod_ff_fw] Error 1 make: *** [all] Error 2 (ove aermod_ff_fw è il nome dell'eseguibile) e di conseguenza quando lancio l'eseguibile mi esce fuori la seguente scritta: -bash: ./aermod_ff_fw: cannot execute binary file Dove è il problema? Premetto che ho installato il g77 e con i codici costituiti da un unico file .f funge perfettamente.
  10. Ti faccio il copia-incolla delle scritte che fa mentre fa il make. nelle ultime 2 righe parla di errore. REBUILDING PROGRAM g77 -p -o ../RUN/aermod_ff_fw main.o geo_rot.o mode.o coef.o tdsl_ff.o struct_hb.o strcoef.o -L. -lbem -lm /usr/bin/ld: main.o bad magic number (not a Mach-O file) /usr/bin/ld: geo_rot.o bad magic number (not a Mach-O file) /usr/bin/ld: mode.o bad magic number (not a Mach-O file) /usr/bin/ld: coef.o bad magic number (not a Mach-O file) /usr/bin/ld: struct_hb.o bad magic number (not a Mach-O file) /usr/bin/ld: strcoef.o bad magic number (not a Mach-O file) /usr/bin/ld: archive: ./libbem.a has no table of contents, add one with ranlib(1) (can't load from it) collect2: ld returned 1 exit status make[1]: *** [../RUN/aermod_ff_fw] Error 1 make: *** [all] Error 2
  11. Dunque, ora ti spiego: Io non ho un file unico .f. Ho una ventina di file.f posti in 2 cartelle che lavorano insieme quando si lancia l'eseguibile che è a sua volta in un altra cartella. Per compilare lancio il comando make, comando che è nella main directory di tutto il codice, e poi lancio l'eseguibile con il comando ./nome_eseguibile. Tutto ciò sul mio computer non va... ergo mi manca evidentemente ancora un passo...
  12. Aggiungo che già nel fare il make mi da una riga con tale messaggio "make[1]: *** [../RUN/aermod_ff_fw] Error 1" (ove aermod_ff_fw è il nome dell'eseguibile) Aggiungo anche che i file e le cartelle così ordinati come li ho qui nel mio computer in lab girano tranquillamente. Ergo dovrebbe essere un problema mio e non del codice.
  13. Ok, ora funge. non so cosa avevo omesso dato che le stringhe le metto col copia-incolla. Comunque ora pare ok. Tuttavia ancora c'e' un problema. Questo è di tipo più opersonale pero'; comunque o espongo dati gli eccellenti assist che mi hai fornito. Ho un codice fortran molto ampio. E' costituito da una serie di cartelle all'interno delle quali ci sono i file sorgenti (*.f), i file dati (*.dat) , l'eseguibile ecc ecc. Dopo aver compilato il codice (dando il comando make), nel lanciare l'eseguibile mi si blocca e non gira dicendomi "./nome_eseguibile: cannot execute binary file" Insomma non mi gira. Dove agire per superare l'ostacolo? Thanks
  14. Allora ho creato da zero questo file .profile e ci ho messo la stringa sopracitata "export.../bin" . Tuttavia ancora, quando spengo il computer e lo riaccendo non vede il comando g77 a meno di non digitare nuovamente su terminale la stringa "export PATH=$PATH:/usrl/local/bin " Cosa ometto? Dove sbaglio?