sergioM

Members
  • Posts

    11
  • Joined

  • Last visited

Everything posted by sergioM

  1. guarda, non so se può esserti utile, ma ti allego l'Aiuto del Finder sull'argomento (scherma blu). ciao
  2. sembrerà banale, ma non riesco a decommentare "#LoadModule php5_module libexec/apache2/libphp5.so" per attivare PHP. quando provo ad aprirlo con il Finder (utilizzando l'account di amministratore) mi dice: "Non posso aprire la cartella “httpd.conf†perché non disponi dei privilegi necessari per visualizzarne il contenuto." che posso fare (oltre che dedicarmi a qualcosa di diverso dal MAC)? (ho un MACBook con Snow Leopard).
  3. grazie. Ma dovresti indicarmi quali comandi dare da Terminali. ciao
  4. Premessa: Nel MacBook ho due account, uno primario (amministratore) e l'altro secondario (standard). Ho installato il pacchetto MAMP dall'account primario (amministratore). Problema: utilizzando l'utente primario, mi si avvia sia Apache che MySql (vado sulla pagina di PHPAdmin e quindi tutto OK) mentre utilizzando l'utente secondario mi si attiva solo Apache (non riesco ad andare sulla pagina di PHPAdmin). Quando avvio MAMP dall'utente secondario, questo è quello che vedo dal LOG di MAMP (mysql_error_log.err) 091215 12:02:26 mysqld_safe Starting mysqld daemon with databases from /Applications/MAMP/db/mysql 091215 12:02:27 [Warning] You have forced lower_case_table_names to 0 through a command-line option, even though your file system '/Applications/MAMP/db/mysql/' is case insensitive. This means that you can corrupt a MyISAM table by accessing it with different cases. You should consider changing lower_case_table_names to 1 or 2 091215 12:02:27 [Warning] One can only use the --user switch if running as root 091215 12:02:27 [Note] Plugin 'FEDERATED' is disabled. 091215 12:02:27 [Note] Plugin 'ndbcluster' is disabled. /Applications/MAMP/Library/libexec/mysqld: Can't find file: './mysql/plugin.frm' (errno: 13) 091215 12:02:27 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it. 091215 12:02:27 InnoDB: Started; log sequence number 0 68704 091215 12:02:27 [ERROR] /Applications/MAMP/Library/libexec/mysqld: Can't find file: './mysql/host.frm' (errno: 13) 091215 12:02:27 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: './mysql/host.frm' (errno: 13) 091215 12:02:27 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/mysql.pid ended Questo è invece quello che vedo da CONSOLE: 15/12/09 12.02.26 [0x0-0x44044].de.appsolute.MAMP[1593] 091215 12:02:26 mysqld_safe Logging to '/Applications/MAMP/logs/mysql_error_log.err'. 15/12/09 12.02.26 [0x0-0x44044].de.appsolute.MAMP[1593] chown: /Applications/MAMP/logs/mysql_error_log.err: Operation not permitted 15/12/09 12.02.26 [0x0-0x44044].de.appsolute.MAMP[1593] 091215 12:02:26 mysqld_safe Starting mysqld daemon with databases from /Applications/MAMP/db/mysql 15/12/09 12.02.27 [0x0-0x44044].de.appsolute.MAMP[1593] 091215 12:02:27 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/mysql.pid ended C'è qualcuno che sa come posso fare per utilizzare MAMP (Apache e MySql) anche dall'utente secondario? Grazie!
  5. innanzi tutto grazie per la risposta. Credo comunque di avere qualche tipo di problema a monte. Ho creato le tabelle come mi hai indicato (InnoDB). Ho fatto delle istantanee al PHPAdmin (che allego). La prima è relativa alla pagina iniziale di PHPAdmn che mi segnala un warning riguardo le caratteristiche di PHPAdmin stesso. La seconda è relativa alle caratteristiche che sono tutte disabilitate (relative al warning). La terza è l'elenco delle tabelle da me create, mentre la quarta e la quinta sono il dettaglio delle due tabelle. La mia esigenza è quella di mettere in relazione tabGenere con tabLibro creando una relazione 1:M (Genere=1, Libro=M) grazie alla colonna IDGenere presente nella tabella tabLibro, . Non riesco a capire come fare questa relazione e se questa impossibilità dipende dal fatto di avere disabilitate alcune caratteristiche (che proprio non saprei, eventualmente, come abilitare) Ciao e grazie.
  6. innanzi tutto grazie per la risposta. Credo comunque di avere qualche tipo di problema a monte. Ho creato le tabelle come mi hai indicato (InnoDB). Ho fatto delle istantanee al PHPAdmin (che allego). La prima è relativa alla pagina iniziale di PHPAdmn che mi segnala un warning riguardo le caratteristiche di PHPAdmin stesso. La seconda è relativa alle caratteristiche che sono tutte disabilitate (relative al warning). La terza è l'elenco delle tabelle da me create, mentre la quarta e la quinta sono il dettaglio delle due tabelle. La mia esigenza è quella di mettere in relazione tabGenere con tabLibro creando una relazione 1:M (Genere=1, Libro=M) grazie alla colonna IDGenere presente nella tabella tabLibro, . Non riesco a capire come fare questa relazione e se questa impossibilità dipende dal fatto di avere disabilitate alcune caratteristiche (che proprio non saprei, eventualmente, come abilitare) Ciao e grazie.
  7. Ciao a tutti, con PHPAdmin ho creato un DB (dbLibreria). Ho poi creato 2 tabelle. La prima è tabGenere con un ID (Primary) e una descrizione (VarChar). La seconda è tabLibro con un ID (Primary), una descrizione VarChar e un IDGenere (INT) index per la relazione con tabGenere. Il problema: come faccio a relazionare le due tabelle? Nel menù OPERAZIONI non vedo alcuna possibilità di realizzare la relazione. Debbo configurare qualcosa? e se si, come? Grazie per l'aiuto, Sergio
  8. Ciao a tutti, con PHPAdmin ho creato un DB (dbLibreria). Ho poi creato 2 tabelle. La prima è tabGenere con un ID (Primary) e una descrizione (VarChar). La seconda è tabLibro con un ID (Primary), una descrizione VarChar e un IDGenere (INT) index per la relazione con tabGenere. Il problema: come faccio a relazionare le due tabelle? Nel menù OPERAZIONI non vedo alcuna possibilità di realizzare la relazione. Debbo configurare qualcosa? e se si, come? Grazie per l'aiuto, Sergio
  9. Trovato l'arcano. Se può essere utile a qualcuno, il mio MAC è configurato per 2 utenti: l'amministratore e un utente "standard". Avviando MAMP dall'utente "standard" non veniva avviato Apache e MySQL. Facendolo dall'utente Amministratore il tutto viene avviato regolarmente. ciao
  10. salve a tutti. sono un nuovo utente che ha bisogno della vostra esperienza. problema: la prima finestra che si apre dopo aver avviato MAMP mantiene i "semaforini" sul rosso e quindi non avvia il server e tanto meno mi da accesso alla Home Page. situazione: ho nei giorni precedenti scaricato e installato MySQL e relativo Administrator e Query Browser. Il data base creato con Administrator funzionava e mi permetteva di fare query con il Query Browser. Ieri ho scaricato MAMP (non MAMP PRO) che a sua volta credo che abbia scaricato nuovamente MySQL. Il MAC è un MAC BOOK Snow Lopard. grazie a chiunque potrà aiutarmi a far funzionare MAMP.