riccardot5765

Members
  • Content Count

    93
  • Joined

  • Last visited

About riccardot5765

  • Rank
    Assiduo

core_pfieldgroups_99

  • Nome
    Riccardo Turcio

Contact Methods

  1. Salve a tutti, ho un piccolo problema di installazione. Tempo fa installai per la prima volta il pacchetto 08 sul mio iMac G5 1.9 iSight e avevo già dei problemi con iMovie che non si avviava per non ricordo quale motivo. Fatto è che trovai una specie di patch che risolse il problema, se non ricordo male legato alla scheda video. Successivamente però ho cancellato tutto. Oggi ho aggiornato a leopard e ho reinstallato la suite 08. Ebbene, quando avvio imovie mi dice "non puoi utilizzare questa versione dell'applicazione con questa versione di Mac OS X". Qualcuno può aiutarmi?
  2. tutto ok, il file che mi hai linkato è perfetto e finalmente ora usa aqua. Visto che te ne intendi, ma maxima risolve anche equazioni differenziali alle derivate parziali? lo chiedo perchè ho visto che per le altre va una meraviglia...
  3. ti ringrazio infinitamente. ora sono il laboratorio ma non appena torno a casa ci do un'occhiata. ad ogni modo sei stato gentilissimo.
  4. si si ho installato tutto, tant'è vero che ora ho una finestra per vedere i grafici che prima non avevo. cmq hai ragione per leopard c'è solo la 5.9, mi sembrava strano che con una nuova ne installasse una vecchia ma controllare non fa male. forse mi sbaglio, ma credo che il tutto dipenda da un'idiozia, tipo una semplice riga da aggiungere a qualche comando.
  5. allora, ho copiato la riga export GNUTERM=aqua nel file .bash_profile. nell'help del comando plot2d non compare quello che compare a te: (C1) ? plot2d 0: PLOT2D :(maxima.info)Definitions for Plotting. 1: PLOT2D_PS :Definitions for Plotting. Enter n, all, none, or multiple choices eg 1 3 : 0 Info from file /sw/share/info/maxima.info: - Function: PLOT2D (expr,range,...,options,..) - Function: PLOT2D ([expr1,expr2,..,exprn],xrange,...,options,..) - Function: PLOT2D (parametric_expr) - Function: PLOT2D ([..,expr,..,parametric_expr,..],xrange,...,options) EXPR is an expression to be plotted on y axis as a function of 1 variable. RANGE is of the form [var,min,max] and expr is assumed to be an expression to be plotted against VAR. In the second form of the function a list of expressions may be given to plot against VAR. Truncation in the y direction will be performed, for the default y range. It may be specified as an option or using SET_PLOT_OPTION. (C1) plot2d(sin(x),[x,-5,5]); (C2) plot2d(sec(x),[x,-2,2],[y,-20,20],[nticks,200]); Anywhere there may be an EXPR you may also use a parametric expression: PARAMETRIC_EXPR is a Maxima list of the form `[parametric, xexpr, yexpr, trange, ..options]' Here XEXPR and YEXPR are functions of 1 variable VAR which is the first element of the range TRANGE. The plot is of the path traced out by the pair `[XEXPR, YEXPR]' as VAR varies in TRANGE. In the following example, we plot a circle, then we do the plot with only a few points used, so that we get a star, and finally we plot this together with an ordinary function of X. (C1) plot2d([parametric,cos(t),sin(t),[t,-%pi*2,%pi*2]]); (C2) plot2d([parametric,cos(t),sin(t),[t,-%pi*2,%pi*2], [nticks,8]]); (C3) plot2d([x^3+2,[parametric,cos(t),sin(t),[t,-5,5]]], [x,-3,3]); per le versioni di maxima, sul sito fink nella sezione pacchetti c'è la versione 5.13 ma con il comando fink install maxima mi ha messo la 5.9 e credo che tutti i problemi nascano da lì. ma se scarico dal sito di fink la versione recente (5.13) poi come la installo? devo prima cancellare quella che ho già giusto? come devo fare? Non uso finkCommander, quindi tutto da terminale. P.S.: complimenti per il tuo sito davvero ben fatto e soprattutto utile.
  6. (C6) gp: "set terminal aqua; set xlabel 10; set ylabel 10;"; (D6) set terminal aqua; set xlabel 10; set ylabel 10; (C7) plot2d(sin(x)/x, [x,-%pi,%pi], [gnuplot_preamble, gp]); Unknown plot option specified: gnuplot_preamble -- an error. Quitting. To debug this try DEBUGMODE(TRUE) questo è lerrore che ottengo copiando le righe che mi hai inviato. se invece faccio un grafico con il parametro [gnuplot_term, aqua] ecco cosa ottengo: (C9) plot2d(F,[X,1,10],[gnuplot_term, aqua]); Unknown plot option specified: gnuplot_term -- an error. Quitting. To debug this try DEBUGMODE(TRUE) ovviamente da gnuplot parte automaticamente aqua. se invece non uso l'pzione mi si apre un terminal strano che si chiama schelter's 2d Plot Window che credo sia stato installato da fink quando ho installato maxima. Per curiosità , sul tuo sito ho visto come settare aqua per gnuplot con il comando ''set terminal aqua'', non c'è niente di simile per maxima? Sarà che aqua non è il massimo ma per quello che serve a me va bene (fa un grafico e me lo fa salvare), quali sono altri terminali gnuplot adeguati? Ad ogni modo mi preme più fare grafici e poterli salvare, cosa che per il momento non posso fare...pensa che schifo di terminale che usa maxima!
  7. darwine visto che sei un esperto di maxima, mi diresti come configurarlo perchè apra i plot con aqua? prima usava x11 poi non mi funzionava più e ora che ho risolto usa un terminal bruttissimo che non puoi nemmeno salvare il file. ho provato ad aggiungere l'opzione [gnuplot_term, aqua] al comando plot2d ma mi dice di non conoscere l'opzione. che devo fa?
  8. bhè, a me invece funziona con il semplice fink install. Però non riesco a far si che maxima diagrammi in aqua. per gnuplot nessun problema però se poi uso maxima allora mi si apre una finestra in cui vedo la funzione ma non posso nemmeno salvare o nient'altro. Ho provato ad aggiungere è [gnuplot_term, aqua] ma mi da errore perchè non conosce l'opzione. Ma è mai possibile che risolto un problema se ne presenti un altro?
  9. Dal momento che mi siete stati di grande aiuto e che sono riuscito a risolvere il problema, posto la soluzione che ho trovato io in modo che forse potrà aiutare anche altri. Premesso che ho fatto tutto dal terminale e che non uso FinkCommander. 1) scaricare il file fink-0.27.8.tar.gz 2) mettere il file nella propria cartella in modo che con il comando ls dato appena si accede al terminale compaia il file nella lista 3) tar xzf fink-0.27.8.tar.gz 4) cd fink-0.27.8 a questo punto non resta che scegliere le opzioni che mano mano ci vengono presentate. In particolare è utile accettare i pacchetti denominati unstable che, sebbene siano stai definiti instabili, quasi mai danno problemi - o perlomeno io non ne ho avuti con quei pacchetti. Aspettando il tempo necessario che compili il tutto si ha una versione funzionante di fink e si possono cancellare il file tar.gz e la relativa cartella scompattata. Ora viene un passo fondamentale. Dare i seguenti comandi: 1) finita linstallazione con il comando ls tornare nella propria home (basta scrivere ls nel terminale che ovviamente non viene chiuso alla fine della compilazione) 2) eseguire . /sw/bin/init.sh (attenzione al punto e agli spazi) 3) eseguire /sw/bin/pathsetup.sh ls 2) e la 3) servono per rendere eseguibile fink da ogni terminale e per scrivere i percorsi cartelle di fink in due appositi file nascosti. In particolare il punto 3) può essere sostituito dal comando pico .profile e copiare in esso la riga del 2) e poi fare lo stesso con il comando pico .bash_profile. Io ho usato il comando illustrato nel punto 3) accettando le modifiche che propone. A questo punto fink funziona correttamente. Per installare un pacchetto fink sarà sufficiente il comando: fink install nome_pacchetto tornando al post, bisogna installare aqua, gnuplot, maxima, non importa in quale ordine
  10. ho provveduto a creare un nuovo thread in cui si parlo solo dei problemi che si possono incontrare per l'installazione di gnuplot, maxima, octave e aqua.
  11. ah, dimenticavo, ovviamente neanche il comando ''fink install nome'' funziona perchè mi dice sempre command not found
  12. dunque, questa è la situazione: dopo un pò di problemi sono riuscito a installare fink, maxima, aqua, gnuplot e octave. All'inizio nessun problema, da terminale scrivendo maxima o gnuplot subito si avviava il programma richiesto. Poi ho deciso di installare octave e devo dire che da quel momento non funziona più niente, nel senso che scrivendo "maxima" si ottiene comando non trovato. Seguendo alcuni consigli ho aperto i file .profile e .bash_profile aggiungengo le righe che mi venivano indicate, ma il problema non è scomparso. Ecco quello che leggo nel terminale: imac-g5-di-riccardo-turcio:~ riccardoturcio$ gnuplot -bash: gnuplot: command not found imac-g5-di-riccardo-turcio:~ riccardoturcio$ maxima -bash: maxima: command not found imac-g5-di-riccardo-turcio:~ riccardoturcio$ octave -bash: octave: command not found questo eseguendo i comandi. Ecco i listati dei file .profile e .bash_profile: # # Your previous .profile (if any) is saved as .profile.mpsaved # Setting the path for MacPorts. export PATH=/opt/local/bin:/opt/local/sbin:$PATH test -r /sw/bin/init.sh && . /sw/bin/init.sh mentre .bash_profile è vuoto. imac-g5-di-riccardo-turcio:~ riccardoturcio$ echo $PATH /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/texbin:/usr/X11/bin se invece trovo maxima e co. nella cartella dove sono e ci clicco sopra due volte cmq non succede niente. Ora, io non ho la minima idea da cosa possa dipende questa assurda situazione (assurda perchè funzionava tutto bene e poi niente più), ma tant'è e devo dire che programmi del genere sono davvero utilissimi, almeno per me. Spero che qualcuno possa aiutarmi. Ad ogni modo potete contattarmi anche tramite msn.
  13. il constenuto del file pico .profile l'ho copiato nel mio post precedente. ma come è possibile che un'ora uso maxima e l'ora dopo mi da comando non trovato se scrivo maxima nel terminale?
  14. ho provato a copiare le linee che mi hai scritto però niente da fare, ancora command not found. però questo è il contenuto del file .profile: # Your previous .profile (if any) is saved as .profile.mpsaved # Setting the path for MacPorts. export PATH=/opt/local/bin:/opt/local/sbin:$PATH test -r /sw/bin/init.sh && . /sw/bin/init.sh anche se io non ho installato niente di tutto ciò con macports ma ho usato fink