Sign in to follow this  
andrea

BUG E SOLUZIONI

Recommended Posts

Guest

Non credo che riavviando da Classic (più esattamente da OS9) si possano aprire i file .dmg. Se non li apre Disk Copy di OSX, ancor meno li apre Disk Copy di OS9. Quindi non preoccuparti se il tuo Mac si avvia solo con X. Dunque, o i file sono corrotti, o lo è Disk Copy, o magari le sue preferenze.

Share this post


Link to post
Share on other sites
Guest

Giulio A.:<font color="ff0000">Succede quanto tenti di aprirli prima di averli scaricati completamente.</font>

Magari! Posted Image

Ti assicuro che succede anche ai file completamente scaricati.

Luciano: <font color="ff0000">Non credo che riavviando da Classic (più esattamente da OS9) si possano aprire i file .dmg.

</font>

No, in effetti la cosa era molto più complicata: non trovo più la fonte, ma in pratica da OS 9 andava a pastrocchiare in qualche file della cartella System di OS X a cui altrimenti sarebbe stato negato l'accesso.

Comunque dall'ultima volta che ho controllato sui forum Apple sembra che finalmente sia stata trovata la causa: si tratta del database di NetInfo che si è in qualche modo danneggiato.

Ci sono le istruzioni per provare a reinstallarlo, qui: http://discussions.info.apple.com/WebX?14@[email protected]

Adesso ci provo, speriamo bene!

Share this post


Link to post
Share on other sites
Guest

Eh, naturalmente il link va riportato tutto intero, compresa la @ centrale... Quello che non capisco è come mai abbia problemi solo con alcuni file... boh Vado!

Share this post


Link to post
Share on other sites
Guest

Luigi, ho letto qualcosa del tuo link. Mi pare una faccenda assai complicata e delicata. Però, se non c'è altra strada, prova. Se non ho capito male, resettando il database di NetInfo, dovrai rifare tutta la noiosissima procedura con la quale, dopo l'installazione di OSX, Apple vuol sapere tutto di te... Auguri.

Share this post


Link to post
Share on other sites
Guest

Funziona!!!! O, almeno, così pare Posted Image

Luciano: <font color="ff0000">Se non ho capito male, resettando il database di NetInfo, dovrai rifare tutta la noiosissima procedura con la quale, dopo l'installazione di OSX, Apple vuol sapere tutto di te...

</font>

Esattamente. Fortunatamente, a parte il fastidio della procedura, tutte le mie impostazioni sono rimaste immacolate, comprese quelle di Internet (nonostante abbia rifiutato di riconfigurarle durante l'installazione).

Fanno eccezione, purtroppo, quelle degli account: sparito tutto, rimane solo l'utente principale di cui però bisogna reimpostare nome e password. Fortunatamente, mettendo lo stesso nome che c'era prima, la directory home e tutto il resto vengono ripristinate.

E ancor più fortunatamente, il mio Mac è praticamente monoutente, avevo creato solo un altro account per eventuali utenti temporanei...

E' andata... meno male perché il problema era davvero fatidioso (e penalizzante, soprattutto)

Share this post


Link to post
Share on other sites
Guest

Sì, compresi tutti quelli che avevo da parte da un bel po' e che non riuscivo ad aprire.

Share this post


Link to post
Share on other sites
Guest

Sono disperato: da oramai una settimana il Jaguar 10.2.3 mi si crasha a random e non riesco a capire il perchè....Ho reinizializzato il disco, reinstallato il sistema più volte ma il problema si ripresenta. Il computer è un iMac 1ghz con 1 giga di ram. Mi succede che, qualsiasi cosa stia facendo, l'applicazione o il finder si chiudono (senza avvisare con "chiusura inaspettata" o similia). Posto quidi seguito uno dei (numerosissimi, ahimè) crash report: qualcuno sa dirmi qualcosa? Grazie e ciao! Date/Time: 2003-06-12 00:52:13 +0200 OS Version: 10.2.3 (Build 6H58) Command: WindowServer PID: 340 Exception: EXC_BAD_INSTRUCTION (0x0002) Code[0]: 0x00000002Code[1]: 0x0016c660 Thread 0 Crashed: Thread 1: #0 0x9003ea88 in semaphore_wait_signal_trap #1 0x9003e8a4 in _pthread_cond_wait #2 0x936f87a4 in CGSLockLock #3 0x937008b0 in CGXLockServerFunnel #4 0x9371bc2c in eventThread #5 0x90020d28 in _pthread_body PPC Thread State: srr0: 0x0016c660 srr1: 0x0008f030 vrsave: 0x00000000 xer: 0x00000000 lr: 0x0016c660 ctr: 0x93759524 mq: 0x00000000 r0: 0x0016c660 r1: 0xbffef590 r2: 0x2800024c r3: 0x00000001 r4: 0x000e6f10 r5: 0x2ca49c6c r6: 0xbffef570 r7: 0xbffef574 r8: 0x000e8cc0 r9: 0xa36f2310 r10: 0x00000000 r11: 0x00000002 r12: 0x93759524 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000 r16: 0x00000000 r17: 0x00000000 r18: 0x00000000 r19: 0x00000000 r20: 0x00000000 r21: 0x00000000 r22: 0x00000000 r23: 0x00000000 r24: 0x00000000 r25: 0x00000000 r26: 0x0000468f r27: 0x000e7040 r28: 0x000e8ca0 r29: 0xbfff77a0 r30: 0xbffef6f4 r31: 0x000000c4

Share this post


Link to post
Share on other sites
Guest

Aggiornare a 10.2.6 non guasta. Succede solo da una settimana? Hai modificato in qualche modo la configurazione HW (aggiunte periferiche, RAM ...) recentemente? Hai qualche aggeggino SW che personalizza il finder?

Share this post


Link to post
Share on other sites
Guest

Ciao Zann, le uniche "cassatine" che ho aggiunto al software originale sono Mplayer e Candybar, di grossi ho Photoshop, Indesign e Toast Titanium...Le periferiche che ho le ho da quando ho preso il Mac (un mese fa) e sono uno scanner, una Epson c82 e un hard disk esterno...La memoria è 512 Applestore e 512 Apple compatibile garantita dal rivenditore...Se c'è qualcuno che sa decifrare i crash log, posso posstarne altri, ne ho a bizzeffe (sigh)

Share this post


Link to post
Share on other sites
Guest

Non che dirti. Magari prova a ripristinare le icone di default e a non usare Candybar per un po'...

Share this post


Link to post
Share on other sites

Di sicuro c'è qualcosa di anomalo. Hai controllato con il CD Apple Hardware Test (in dotazione al Mac)?

Confrontando con i miei crash.log: non ho mai avuto un crash di WindowServer. Questi (WindowServer) dovrebbe sovrintendere alla gestione di finestre e quant'altro e potrebbe essere corrotto... ma se hai reinstallato il Sistema Operativo.....

CandyBar? Potrebbe essere, in verità....

In ogni caso controlla tutte le intestazioni dei crash log:

Command (cosa hai chiesto di fare)

PID (non lo so...)

Exception (ho sempre visto questo: EXC_BAD_ACCESS (0x0001), praticamente accesso non corretto)

Codes: ho avuto un solo codice KERN_INVALID_ADDRESS (0x0001) at .....; gli altri erano tutti KERN_PROTECTION_FAILURE (0x0002) at .....

Se Command riguarda sempre WindowServer probabilmente è meglio buttare CandyBar e riparare i privilegi (tanto per non sapere né leggere né scrivere Posted Image )

Ciao

Francesco

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this