Cam non funzionante e reinstallazione sistema operativo


Recommended Posts

Ciao a tutti,

ho un MacBook Pro 13".

La videocamera ha funzionato per poco tempo quando l'ho acquistato e poi mai piu', se guardo da sysetm profiler>usb non la vedo proprio.

E' ancora in garanzia quindi oggi ho chiamato l'assistenza; mi hanno consigliato, prima di portarlo in riparazione, il reset del System Management Controller (SMC) (che non ha portato frutti) e poi la reinstallazione del sistema operativo.

Avete altre soluzioni piu' "light" da provare? La reinstallazione del SO da DVD funziona veramente in modo che tutto (applicazioni, dati, settaggi) sia esattamente come prima? (cosi' mi hanno detto al telefono).

Grazie.

Link to post
Share on other sites
  • 2 weeks later...

Aggiungo un dettaglio: non capisco se il reset del SMC e' andato a buon fine:

da qua: Computer portatili Apple: reset del controller di gestione del sistema (SMC)

si dice che

"Puoi anche controllare visivamente il reset dell'SMC osservando il LED sull'adattatore; al termine dell'operazione, il LED si spegnerà temporaneamente. "

mentre la stessa pagina in inglese Intel-based Macs: Resetting the System Management Controller (SMC)

dice l'esatto opposto!!!

"Note: The LED on the MagSafe power adapter does not change states or temporarily turn-off when you reset the SMC."

Per la croanca: a me il led non si spegne...quindi non capisco se e' stato fatto o meno...

Grazie.

Link to post
Share on other sites

Piuttosto non capisco perché NON dovrebbe essere andato a buon fine (se hai seguito le istruzioni e rispettato gli eventuali tempi con tasto premuto).

Rispondo alla domanda del tuo primo post:

La reinstallazione del SO da DVD funziona veramente in modo che tutto (applicazioni, dati, settaggi) sia esattamente come prima?

Dati --> Assolutamente SI

Settaggi --> Assolutamente SI (es. scrivania, salvaschermo, tempi di standby, ...)

Applicazioni --> Secondo me potresti avere problemi con tutte quelle che NON sono Drag&Drop (leggasi; che si installano semplicemente copiandole nella cartella Applicazioni). In particolare se sono applicazioni che all'atto dell'installazione salvano cose nelle cartelle MacintoshHD\Library oppure MacintoshHD\System\Library\ApplicationSupport (i percorsi delle cartelle te li ho scritti a memoria, quindi magari sono un pelo diversi)

Se non ricordo male ad esempio la CS3 è da re-installare (credo valga anche per le versioni 4 e 5).

Ovvio che se non hai fatto armeggi vari e hai tutti i software originali, al massimo dovrai re-installare un paio di cose.

Archivia&Installa (che tu chiami "reinstallazione del SO"... ocio a non sbagliare e formattare!) è un rimedio tipicamente molto efficace in situazioni come la tua.

ps. se provi ad avviare photoboot che succede?

Link to post
Share on other sites

Ti ringrazio innanzitutto per la risposta.

Piuttosto non capisco perché NON dovrebbe essere andato a buon fine (se hai seguito le istruzioni e rispettato gli eventuali tempi con tasto premuto).

Si', sono abbastanza sicuro infatti, ma me lo chiedo proprio perche' la documentazione ufficiale e' molto confusa! Addirittura nella versione italiana si dice di attendere questi 5 secondi, in quella inglese di secondi non si parla; e poi perche' mi sembrerebbe normale avere un modo per capire se questo reset e' stato in effetti eseguito.

Rispondo alla domanda del tuo primo post:

Dati --> Assolutamente SI

Settaggi --> Assolutamente SI (es. scrivania, salvaschermo, tempi di standby, ...)

Applicazioni --> Secondo me potresti avere problemi con tutte quelle che NON sono Drag&Drop (leggasi; che si installano semplicemente copiandole nella cartella Applicazioni). In particolare se sono applicazioni che all'atto dell'installazione salvano cose nelle cartelle MacintoshHD\Library oppure MacintoshHD\System\Library\ApplicationSupport (i percorsi delle cartelle te li ho scritti a memoria, quindi magari sono un pelo diversi)

Se non ricordo male ad esempio la CS3 è da re-installare (credo valga anche per le versioni 4 e 5).

Ovvio che se non hai fatto armeggi vari e hai tutti i software originali, al massimo dovrai re-installare un paio di cose.

Non ho capito quel e' la differenza tra applicazione drag&drop e le altre.

Per quanto riguarda la cartella dei dati non saprei, dovrei far passare una a una le applicazioni e cercare di capire dove salvano i dati (cosa magari neanche documentata). Ad esempio mysql (non solo all'installazione ma anche durante il suo uso) se non ricordo male salva i database in una dir sotto Library. Quelle che citi tu sono le uniche cartelle in cui una tipica applicazione per mac os salva i dati?

Archivia&Installa (che tu chiami "reinstallazione del SO"... ocio a non sbagliare e formattare!) è un rimedio tipicamente molto efficace in situazioni come la tua.

Ok, si' credo che intendessero "archivia&installa". Ma non esiste nessun altro modo piu' veloce e meno rischioso per capire se in effetti si tratta di un problema hardware (come sono portato a pensare) o software?

ps. se provi ad avviare photoboot che succede?

Dice che non ho cam collegata, come le altre applicazioni.

Link to post
Share on other sites

Non ho capito quel e' la differenza tra applicazione drag&drop e le altre.

Drag&Drop --> Si installano semplicemente copiando un icona o una cartella nella dir Applicazioni

Altre --> Si installano con un installer che potrebbe fare di più che non copiare nella dir Applicazioni

Per quanto riguarda la cartella dei dati non saprei, dovrei far passare una a una le applicazioni e cercare di capire dove salvano i dati (cosa magari neanche documentata). Ad esempio mysql (non solo all'installazione ma anche durante il suo uso) se non ricordo male salva i database in una dir sotto Library. Quelle che citi tu sono le uniche cartelle in cui una tipica applicazione per mac os salva i dati?

Facciamo prima (ed evitiamo mie inesattezza) se leggi bene

qui Mac OS X 10.4, 10.5: informazioni sulle opzioni di installazione

e anche qui Mac OS X: informazioni sulla funzione Archivia e installa

Tra l'altro vedrai che /Library/Application Support rimane invariata al contrario di quanto credessi).

Ciò nonostante, un po' qua e un po' la, ti informano che "Alcuni elementi software di terze parti potrebbero andare persi. Se dopo l'esecuzione di Archivia e installa dei programmi software di terze parti non funzionano, reinstallarli o contattare il fornitore."... quindi valuta bene tu se sei nelle condizioni di recuperare eventualmente tutti i software di cui hai bisogno (il backup di documenti vitali è comunque consigliabile... non si sa mai!!!)

Ok, si' credo che intendessero "archivia&installa". Ma non esiste nessun altro modo piu' veloce e meno rischioso per capire se in effetti si tratta di un problema hardware (come sono portato a pensare) o software?

Apple hardware test?

Intel-based Macs: Using Apple Hardware Test

Saluti e come massima eventuale forma di ringraziamento... tienimi aggiornato! ;)

Link to post
Share on other sites

Ciò nonostante, un po' qua e un po' la, ti informano che "Alcuni elementi software di terze parti potrebbero andare persi. Se dopo l'esecuzione di Archivia e installa dei programmi software di terze parti non funzionano, reinstallarli o contattare il fornitore."... quindi valuta bene tu se sei nelle condizioni di recuperare eventualmente tutti i software di cui hai bisogno (il backup di documenti vitali è comunque consigliabile... non si sa mai!!!)

Immaginavo che il tipo dell'assistenza l'avesse fatta troppo semplice :(

Apple hardware test?

Intel-based Macs: Using Apple Hardware Test

Saluti e come massima eventuale forma di ringraziamento... tienimi aggiornato! ;)

Ok, grazie ancora, provo l'hardware test appena riesco :)

Link to post
Share on other sites
  • 3 weeks later...

Eccomi, con un po' di ritardo.

Ho eseguito l'hardware test ed e' tutto regolare. In realta' pero' mi sembra che faccia solo un controllo della RAM o sbaglio? Ho fatto sia quello breve che quello esteso.

Il problema della webcam rimane. E se ne e' aggiunto un altro...ho notato che anche il bluetooth non funziona (non l'avevo mai provato fino ad ora). Se faccio mela->Informazioni su questo Mac->Piu' informazioni->Hardware->Bluetooth vedo "Nessuna informazione trovata.". Ovviamente do per scontato che un macbook pro acquistato meno di un anno fa abbia il bluetooth giusto?

Idee? Vedete qualche collegamento (a livello di problema hardware) tra queste due cose?

Grazie.

Link to post
Share on other sites

Archivia & Installa?

:D

Ma mi sembra cosi' strano che sia bluetooth che cam non funzionino per problemi software...tra l'altro ho installato pochi applicazioni su questo computer, e' normale che ci nascano questi problemi? Pensavo che il passaggio al mac mi preservasse da queste tribolazioni...

A naso a me sembra piu' un problema hardware ma se voi esperti del mondo mac mi dite che capita abbastanza spesso faccio una prova...

PS non e' per non provare, e' che tra capire dove sono i dati delle varie applicazioni, backup di tutto ed eventuali ripristini se Archivia & installa non mi conserva tutti i dati puo' essere che ci voglia un giorno di lavoro...

grazie!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now