problema tastiera macbook os x lion


giannitroja
 Share

Recommended Posts

problema enorme.

pulivo la tastiera e tenevo pigiato il tasto TAB, mi si avvia il mac e la tastiera smettere di funzionare, ovvero funziona solo con caps lock attivato scrivendo in maiuscolo, operazione che mi consente anche di usare il trackpad normalmente altrimenti funziona "invertito" (qualsiasi pressione attiva il tasto destro, spostarsi con due dita attiva lo zoom...).

ho provato a riavviare tenendo premuto il tasto tab, non cambia nulla. ho solo notato attivando il visore tastiera, che questa operazione cambia il tipo di tastiera visualizzato (da normale a estesa con tastierino numerico)

se spengo il caps lock in visore tastier il tasto ctrl mi appare come permanentemente pigiato...

dopo vari tentativi, seguendo tutte le guide trovate, mi sono deciso a reinstallare lion.... problema NON risolto!!!!

ps: notate che se non posso scrivere in minuscolo non riesco a scrivere la password per abilitare le modifiche di sistema...

pps: se uso mouse apple bluetooth il problema non cambia, presumo sia lo stesso con tastiera mac wireless che proverò ad usare domani....

AIUTO!!!!

Link to comment
Share on other sites

Mi viene in mente...

Prova ad aprire Mostra Visore Tastiera.

(Dalla barra dei menù, se non trovi l'icona abilitala dalle Preferenza di Sistema)

Guarda se per caso non ci fosse qualche tasto Fn od altro tasto funzionale bloccato...

Altro metodo di indagine, visto questo post significa che non sei il solo

https://discussions.apple.com/thread/1548109?start=0&tstart=0

Riavvia e posta il system log da Console dal riavvio

Link to comment
Share on other sites

visore tastiera mi fa vedere che quando spengo caps lock resta attivato il tasto ctrl. se lo deseleziono da visore tastiera non cambia nulla...

il post l'ho visto mi dice di resettare la PRAM come suggerivi tu.

solo che se pigio comand-option-p-r mi succede che mi compare la finestra dove si può reinstallare il sistema operativo. da li ho verificato e corretto gli errori del disco fisso. ma non riesco proprio a resettare sta cavolo di pram.

sono ancora in alto mare...

cmq

intanto ti ringrazio e ti posto il system log (spero sia quello giusto...)

Nov 27 19:38:58 localhost bootlog[0]: BOOT_TIME 1322419138 0

Nov 27 19:38:59 localhost com.apple.launchd[1]: *** launchd[1] has started up. ***

Nov 27 19:38:59 localhost fseventsd[19]: event logs in /.fseventsd out of sync with volume. destroying old logs. (688 0 752)

Nov 27 19:38:59 localhost fseventsd[19]: log dir: /.fseventsd getting new uuid: 4CB3B59C-2069-491E-8949-11DFFA8E4559

Nov 27 19:39:00 localhost UserEventAgent[11]: starting CaptiveNetworkSupport as SystemEventAgent built May 25 2011 12:27:35

Nov 27 19:39:00 localhost UserEventAgent[11]: CaptiveNetworkSupport:CreateInterfaceWatchList:2788 WiFi Devices Found. :)

Nov 27 19:39:00 localhost UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - PreProbe

Nov 27 19:39:00 localhost UserEventAgent[11]: CaptiveNetworkSupport:CaptiveSCRebuildCache:81 Failed to get service order

Nov 27 19:39:00: --- last message repeated 1 time ---

Nov 27 19:39:00 localhost UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - PreProbe

Nov 27 19:39:00 localhost UserEventAgent[11]: CaptiveNetworkSupport:CaptiveSCRebuildCache:81 Failed to get service order

Nov 27 19:39:00: --- last message repeated 1 time ---

Nov 27 19:39:00 localhost UserEventAgent[11]: CertsKeychainMonitor: configuring

Nov 27 19:39:01 localhost airportd[28]: _processDLILEvent: en0 attached (down)

Nov 27 19:39:01 localhost UserEventAgent[11]: CaptiveNetworkSupport:CaptiveSCRebuildCache:81 Failed to get service order

Nov 27 19:39:01: --- last message repeated 1 time ---

Nov 27 19:39:01 localhost UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - PreProbe

Nov 27 19:39:01 localhost configd[14]: bootp_session_transmit: bpf_write(en0) failed: Network is down (50)

Nov 27 19:39:01 localhost configd[14]: DHCP en0: INIT transmit failed

Nov 27 19:39:01 localhost UserEventAgent[11]: ServermgrdRegistration cannot load config data

Nov 27 19:39:01 localhost UserEventAgent[11]: get_backup_share_points no AFP

Nov 27 19:39:01 XXXYYY configd[14]: setting hostname to "XXXYYY.local"

Nov 27 19:39:01 XXXYYY configd[14]: network configuration changed.

Nov 27 19:39:03 XXXYYY systemkeychain[32]: done file: /var/run/systemkeychaincheck.done

Nov 27 19:39:04 XXXYYY com.apple.ucupdate.plist[50]: ucupdate: Checked 1 update, no match found.

Nov 27 19:39:04 XXXYYY com.apple.pfctl[57]: No ALTQ support in kernel

Nov 27 19:39:04 XXXYYY com.apple.pfctl[57]: ALTQ related functions disabled

Nov 27 19:39:04 XXXYYY mDNSResponder[61]: mDNSResponder mDNSResponder-320.10 (Aug 2 2011 19:56:51) starting OSXVers 11

Nov 27 19:39:04 XXXYYY configd[14]: network configuration changed.

Nov 27 19:39:04: --- last message repeated 1 time ---

Nov 27 19:39:04 XXXYYY mDNSResponder[61]: D2D_IPC: Loaded

Nov 27 19:39:04 XXXYYY mDNSResponder[61]: D2DInitialize succeeded

Nov 27 19:39:04 XXXYYY com.apple.usbmuxd[49]: usbmuxd-263 on Aug 23 2011 at 00:44:06, running 64 bit

Nov 27 19:39:04 XXXYYY mds[60]: (Normal) FMW: FMW 0 0

Nov 27 19:39:05 XXXYYY netbiosd[59]: Unable to start NetBIOS name service:

Nov 27 19:39:05 XXXYYY mds[60]: (/.Spotlight-V100/Store-V2/0EA23C91-09B6-4031-B78E-DFA873284BF3)(Error) IndexPath in openReverseStore:Successfully recovered from shadow with state d00d0dd0

Nov 27 19:39:05 XXXYYY loginwindow[63]: Login Window Application Started

Nov 27 19:39:06 XXXYYY loginwindow[63]: **DMPROXY** Found `/System/Library/CoreServices/DMProxy'.

Nov 27 19:39:06 XXXYYY com.apple.launchctl.LoginWindow[98]: com.apple.findmymacmessenger: Already loaded

Nov 27 19:39:07 XXXYYY loginwindow[63]: Login Window Started Security Agent

Nov 27 19:39:07 XXXYYY airportd[28]: _doAutoJoin: Already associated to “defaultâ€. Bailing on auto-join.

Nov 27 19:39:07 XXXYYY SecurityAgent[104]: Echo enabled

Nov 27 19:39:08 XXXYYY SecurityAgent[104]: User info context values set for Francesco

Nov 27 19:39:08 XXXYYY SecurityAgent[104]: Login Window login proceeding

Nov 27 19:39:08 XXXYYY loginwindow[63]: Login Window - Returned from Security Agent

Nov 27 19:39:08 XXXYYY loginwindow[63]: USER_PROCESS: 63 console

Nov 27 19:39:08 XXXYYY airportd[28]: _doAutoJoin: Already associated to “defaultâ€. Bailing on auto-join.

Nov 27 19:39:08 XXXYYY com.apple.launchd.peruser.501[115] (com.apple.ReportCrash): Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self

Nov 27 19:39:08 XXXYYY com.apple.launchctl.Aqua[117]: load: option requires an argument -- D

Nov 27 19:39:08 XXXYYY com.apple.launchctl.Aqua[117]: usage: launchctl load [-wF] [-D <user|local|network|system|all>] paths...

Nov 27 19:39:09 XXXYYY configd[14]: network configuration changed.

Nov 27 19:39:09 XXXYYY com.apple.launchd.peruser.501[115] (com.apple.launchctl.Aqua[117]): Exited with code: 1

Nov 27 19:39:09 XXXYYY UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - Probe

Nov 27 19:39:09 XXXYYY UserEventAgent[11]: CaptiveNetworkSupport:CNSPreferencesBuildSSIDLookup:278 ssidLookup:

Nov 27 19:39:09 XXXYYY UserEventAgent[11]: <empty>

Nov 27 19:39:09 XXXYYY UserEventAgent[11]: CaptiveNetworkSupport:CaptiveStartDetect:2343 Bypassing probe on default because it is protected and not on the exception list

Nov 27 19:39:09 XXXYYY configd[14]: network configuration changed.

Nov 27 19:39:09 XXXYYY UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - Unknown

Nov 27 19:39:10 XXXYYY UserEventAgent[11]: CaptiveNetworkSupport:CNSServerRegisterUserAgent:187 new user agent port: 24847

Nov 27 19:39:12 XXXYYY com.apple.dock.extra[147]: Could not connect the action buttonPressed: to target of class NSApplication

Nov 27 19:39:12 XXXYYY com.apple.dock.extra[147]: 2011-11-27 19:39:12.613 com.apple.dock.extra[147:1707] Could not connect the action buttonPressed: to target of class NSApplication

Nov 27 19:39:12 XXXYYY com.apple.dock.extra[147]: Could not connect the action buttonPressed: to target of class NSApplication

Nov 27 19:39:12 XXXYYY com.apple.dock.extra[147]: 2011-11-27 19:39:12.615 com.apple.dock.extra[147:1707] Could not connect the action buttonPressed: to target of class NSApplication

Nov 27 19:39:12 XXXYYY com.apple.dock.extra[147]: Could not connect the action buttonPressed: to target of class NSApplication

Nov 27 19:39:12 XXXYYY com.apple.dock.extra[147]: 2011-11-27 19:39:12.616 com.apple.dock.extra[147:1707] Could not connect the action buttonPressed: to target of class NSApplication

Nov 27 19:39:12 XXXYYY com.apple.dock.extra[147]: Could not connect the action buttonPressed: to target of class NSApplication

Nov 27 19:39:12 XXXYYY com.apple.dock.extra[147]: 2011-11-27 19:39:12.618 com.apple.dock.extra[147:1707] Could not connect the action buttonPressed: to target of class NSApplication

Nov 27 19:39:13 XXXYYY ntpd[46]: proto: precision = 1.000 usec

Nov 27 19:39:13 XXXYYY WindowServer[91]: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

Nov 27 19:39:13 XXXYYY loginwindow[63]: In 'CFPasteboardSetData', file /SourceCache/CF/CF-635.15/AppServices.subproj/CFPasteboard.c, line 3012, during unlock, spin lock 0x10b0f78b8 has value 0x0, which is not locked. The memory has been smashed or the lock is being unlocked when not locked.

Nov 27 19:39:14 XXXYYY [0x0-0x10010].com.tomtom.HOMERunnerApp[164]: TomTom HOME runner started.

Nov 27 19:39:14 XXXYYY [0x0-0x10010].com.tomtom.HOMERunnerApp[164]: CHOMERun::NotifyChanged

Nov 27 19:39:14: --- last message repeated 1 time ---

Nov 27 19:39:14 XXXYYY MagicPrefs[166]: Found 'noMenubarIcon', not showing icon

Nov 27 19:39:15 XXXYYY com.apple.launchd.peruser.501[115] ([email protected][162]): Exited with code: 1

Nov 27 19:39:19 XXXYYY NML2NDeviceObserver[160]: Executable to id(de.novamedia.Vodafone Mobile Broadband) keychain(None)

Nov 27 19:39:19 XXXYYY NML2NDeviceObserver[160]: env(L2N_ID=de.novamedia.Vodafone Mobile Broadband)

Nov 27 19:39:19 XXXYYY MagicPrefs[166]: Added login item file://localhost/Applications/Utilities/MagicPrefs.app/

Nov 27 19:39:20 XXXYYY MagicPrefs[166]: Driver version 220.62.1 - 220.62.1 (220062001000000)

Nov 27 19:39:20 XXXYYY MagicPrefs[166]: There is no Magic Trackpad paired on this machine

Nov 27 19:39:20 XXXYYY MagicPrefs[166]: +MacBook Glass Trackpad found

Nov 27 19:39:20 XXXYYY MagicPrefs[166]: ++Started tracking device <MTDevice 0x7fb7b30c9600 [0x7fff78001f40]>.

Nov 27 19:39:20 XXXYYY MagicPrefs[166]: Event tap created 0x7fb7b2ceae10

Nov 27 19:39:20 XXXYYY MagicPrefs[166]: Magicprefs 2.3.2 (77) loaded on OSX Version 10.7.2 (Build 11C74) by com.apple.loginwindow

Nov 27 19:39:21 XXXYYY MagicPrefsPlugins[172]: Spotlight query kMDItemDisplayName == '*.MPplugin' did not find anything

Nov 27 19:39:30 XXXYYY UserEventAgent[11]: servermgr_certs[11] -[CertsRequestHandler(HelperAdditions) identitiesFromKeychain:]: SecItemCopyMatching (err = -25300)

Nov 27 19:39:30 XXXYYY com.apple.UserEventAgent-System[11]: SecItemCopyMatching: Impossibile trovare nel portachiavi l’elemento specificato.

Nov 27 19:39:30: --- last message repeated 1 time ---

Nov 27 19:39:30 XXXYYY UserEventAgent[11]: servermgr_certs[11] -[CertsRequestHandler(HelperAdditions) identitiesFromKeychain:]: SecItemCopyMatching (err = -25300)

Nov 27 19:39:30 XXXYYY UserEventAgent[11]: CertsKeychainMonitor: ready to process keychain & timer events

Nov 27 19:39:52 XXXYYY login[186]: USER_PROCESS: 186 ttys000

Nov 27 19:39:55 XXXYYY login[186]: DEAD_PROCESS: 186 ttys000

Nov 27 19:40:09 XXXYYY login[199]: USER_PROCESS: 199 ttys000

Nov 27 19:41:09 XXXYYY login[199]: DEAD_PROCESS: 199 ttys000

Link to comment
Share on other sites

Il visore tastiera comunque denuncia un blocco di tasto, lo sblocco software non penso sia una soluzione.

Dipende anche da cosa hai inteso con "pulire la tastiera", se stavi usando liquidi o solventi, anche solo per inumidire, una stilla più l'accensione potrebbero aver causato il solito banale incidente...

Il log a prima vista non denuncia cose relative alla tastiera, ci sono dei messaggi che non mi sembrano conosciuti, farò qualche indagine, ma ci vuole qualche tempo.

E nel complesso non trovo anomalie evidenti.

Che cosa intendevi prima, quando hai scritto: "l'unica cosa mi modificano il tipo di tastiera che vedo con visore tastiera".

Puoi eventualmente postare un'istantanea o specificare di che si tratta?

Link to comment
Share on other sites

Il layout della tastiera dovrebbe trovarsi in Sistema -> Libreria -> Keyboard Layouts col nome AppleKeyboardLayouts.bundle.

Ma ovviamente non è una preferenza, quindi come ripristinarlo (fosse corrotto) non saprei.

Tutto OK nelle Preferenze di Accesso universale? ... ed in Tastiera -> Abbreviazioni da tastiera: Accesso universale?

Prova un "Ripristina default".

___________________________________________

Ricerche con Google nel Forum e nel Sito MacityNet

Link to comment
Share on other sites

Sul layout della tastiera avevamo già visto, se Giannitroja non ha Xcode non potrà verificare i file di preferenze.

Basterebbe verificare se i file di preferenze info e version, che si vedono nell'immagine postata da me hanno una data più recente dell'installazione.

Come vedi ho due file modificati nella cartella dei linguaggi, che toccai per un piccolo esperimento, tutto il resto è immutato.

Se fosse solo quello basterebbe recuperare i file originali dall'installer.

Ho rivisto i log, non c'è nulla a carico della tastiera o delle funzionalità connesse (naturalmente trattandosi di log è solo un parere...)

Sarei praticamente convinto che sia un problema hardware.

L'unica difformità finora trovata è infatti quella mostrata dal visore tastiera, un tasto funzioni bloccato.

La conferma ce la potrà dare solo il collegamento con una tastiera usb o bluetooth esterna.

Se funzionasse sarebbe la prova di quanto detto.

Nel caso sarebbe prima da provare un reset della pram e se non va, assistenza

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share