Sign in to follow this  
luigi351

[Installazione Mysql]-Mac Os X-Leopard 10.5

Recommended Posts

Salve a tutti,

il vostro forum è stato sempre utilissimo,ma non riesco in nessun modo a risolvere questo problema:

ho un MacBook con Leopard v. 10.5 e vorrei installare mysql v.5.0.96.

Installo mysql con il file.dmg,dopodichè mi trovo mysql in /usr/local ma arrivato il momento che devo lanciare il db non funziona.Manca il socket di comunicazione mysql.sock,in rete ho trovato vari metodi per avviare il demone manualmente,ad esempio "/etc/init.d/mysql start" oppure "/etc/rc.d/mysql start" oppure "service mysqld start",ma niente non trovo nemmeno le directory init.d e rc.d .

Non so più cosa fare,c'è qualcuno che gentilmente mi aiuta a risolvere questo problema?

Grazie mille

Share this post


Link to post
Share on other sites

Benvenuto Luigi.

Non è più facile installare MAMP?

La versione attuale è adatta anche a Snow Leopard ed ha MySQL 5.1.44.

L'ultima volta che l'ho fatto a mano (con Terminale, non hai altro accesso a quelle directory) era sette anni fa.

Trovavo una difficoltà con la creazione delle tabelle del database per via di un comando non capito bene.

Chiesi qui sul Forum e qualcuno mi disse: "Ma perché non installi MAMP?"...

Share this post


Link to post
Share on other sites

Grazie faxus,

conosco già MAMP ed è per questo che sto impazzendo,MAMP non mi avvia il Server MySQL! Io praticamente non riesco in nessuno modo ad avviare un db sul mio macbook! :(

Grazie ancora

Share this post


Link to post
Share on other sites

Buongiorno faxus,mi sono svegliato con il pensiero! :)

Purtroppo c'è poco da descrive,scarico MAMP 1.9.6 e lo trascino nelle Applicazioni,fin qui tutto bene.

Avvio MAMP parte il Server Apache,ma MySQL Server resta sempre rosso...quindi inattivo,nonostante ho impostato le porte correttamente.

Dimmi come posso procedere.

Grazie mille

Share this post


Link to post
Share on other sites

... ma MySQL Server resta sempre rosso...quindi inattivo,nonostante ho impostato le porte correttamente....

Queste sono le impostazioni.

Le info del Finder sulla cartella MAMP:

Posted Image

Le porte corrette:

Posted Image

Share this post


Link to post
Share on other sites

Dispiace deluderti ancora e soprattutto dispiace a me non poter usare il db,ma ho i tuoi stessi permessi inoltre imposto le tue stesse porte...ma niente da fare! :( Mi sorge una domanda spontanea,e qui ritorno al Terminale perchè da li posso vedere tutto...se a me manca questo benedetto socket mysql.sock come fa MAMP a comunicare con il db?

Grazie ancora

Share this post


Link to post
Share on other sites

La versione attuale di MAMP è la 2.0.5.

Aggiornala, anzi disinstalla la tua e reinstalla quella corretta.

(Poi esegui tutto passo passo per la configurazione, come da manuale.)

Se vuoi evitare qualsiasi problema connesso con impostazione di privilegi, subito dopo l'installazione esegui, da Terminale:

sudo chown root:admin /
Accapo, dai la password, poi:

sudo chmod -R 770 /Applications/MAMP

Quando vai cambiare le porte sulle preferenze e rimane la lucetta rossa senza che si avvii il server, subito dopo dai questo comando

killall -9 mysqld
Poi riavvia il server

Share this post


Link to post
Share on other sites

Si so che la versione di MAMP in uso è la 2.0.5,ma questa versione richiede una versione 10.6 o superiore...io ho la 10.5.

Non so cosa è successo,ha sempre funzionato...se ti servono altre informazioni riguardanti il Terminale,fammi sapere.

Sono spacciato.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this