Sign in to follow this  
luigi351

[Installazione Mysql]-Mac Os X-Leopard 10.5

Recommended Posts

Veramente ti dovrebbero essere rimaste anche bin, sbin e share...

Confermalo, o altrimenti vorrà dire che hai anche problemi all'installazione del sistema.

Se hai eliminato le cartelle dette relative a MySQL, ricomincia daccapo la procedura, installa MAMP ecc.

Gli altri eventuali problemi li abbiamo già affrontati e in caso di errore o qualcosa che non va sai già cosa fare.

Fatto questo procedi per la tua strada.

Rimane solo una cosa da sapere su eventuali errori.

Ma ancora non ci siamo arrivati, semmai leggeremo il log interno a MAMP, se ci saranno problemi relativi alle cartelle del database.

Ma se è come presumo, non si verificheranno

Share this post


Link to post
Share on other sites

Allora,in /usr/ io ho questo:

X11 bin lib	local	shareX11R6 include libexec	sbin standalone

mentre in /usr/local mi ritrovo questo:

include	lib
Dimmi se c'è qualcosa di anomalo,ora reinstallo MAMP.

Grazie

Share this post


Link to post
Share on other sites

Nada! :( Disinstallato MAMP,reinstallato impostato le porte e seguita la procedura del passo #10.

Niente da fare il pallino MySQL Server mi rimane rosso e il Terminale mi risponde come nei passi precedenti,nessun cambiamento.

Qualcosa di grave?

Share this post


Link to post
Share on other sites

Forse, ma non irrimediabile.

Ti dovrei consigliare di applicare l'aggiornamento combo dopo aver fatto un archivia e reinstalla.

Ma vorrei essere certo che anche in Leopard la cartella /usr/local contiene bin, sbin e share come in Lion.

Aspettiamo conferma

Share this post


Link to post
Share on other sites

Nessuno ha Leopard?

Può fare questa semplice verifica, cortesemente?

Menù Vai del Finder > Vai alla cartella e scrivere /usr/local nella finestra che appare, così:

Posted Image

e dare l'elenco che compare del suo contenuto.

Che dovrebbe essere questo, anche in OS X 10.5

Posted Image

Così potremo verificare effettivamente se il problema di Luigi è un sistema danneggiato, oppure no

Share this post


Link to post
Share on other sites

Eccomi qui,dunque ho reinstallato tutto..adesso nella cartella 'usr' è presente questo:

X11 bin libexec shareX11R6 lib sbin standalone
non è più presente la cartella 'local',come procedo?

Share this post


Link to post
Share on other sites

Bene,smanettando ho avviato finalmente il demone 'mysql.sock' e ho anche impostato il percorso a var/mysql/mysql.sock.

Fatto questo ho molti dubbi riguardo alcune cose,allora io riesco ad avviare il demone entrando da root e digitando ./mysqld_safe --user=root,ma perchè va messo --user?!

In seguito avvio il server andando in /usr/local/mysql/support-files e digitando ./mysql.server start.

Dopo riandando in usr/local/mysql/bin digitando ./mysql avvio MySql e funziona,ho provato a creare il Db e tutto andava(si fino a quando non ho impostato la pwd per il db).

Dopo aver messo la pwd al db faccio le stesse identiche operazione ma quando vado a eseguire ./mysql mi stampa questo:

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
Inoltre PhpMyAdmin mi dice:

L'estensione mcrypt è mancante. Controlla la tua configurazione di PHP.
Cos'è mcrypt e come posso configurarlo?

Grazie ancora

Share this post


Link to post
Share on other sites

Non so se nel frattempo hai risolto o passato la mano.

In genere all'errore si ovvia reimpostando la password di root, dopo aver arrestato il server.

Se non funziona posta e vedremo di correggere l'errore, è abbastanza comune e ci sono soluzioni pronte.

Per quel che riguarda mcyript, se l'avviso si presentasse ancora basta aggiungere una stringa al file php.ini

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this