Sign in to follow this  
jerys1974

Come Eliminare modello personalizzato?

Recommended Posts

Ciao a tutti,

oggi ho avuto la brillante idea di creare un modello di mail, aggiungendo semplicemente un'immagine ad un modello pre-esistente e decidere di registrarla come modello. Non l'avessi mai fatto... Mail si è incaxxxxo ed ora, come provo ad aprire l'icona modelli, mi salta mail.

Riavvii inutili.

Tengo a precisare che, visto che per lavoro, mi serviva di inviare sempre la stessa lettera con un'immagine, non è che ho modificato i modelli da html dentro Resources.

I passaggi che ho eseguito sono stati:

- aprire "mostra modelli"

- sceglierne uno

- aggiungere l'immagine .jpg

- registra come modello

Ecco, ora non funziona più. Sto cercando di eliminare il modello personalizzato o ripristinare mail ma... chi mi da una mano :)

Grazie a tutti

Share this post


Link to post
Share on other sites

... ho avuto la brillante idea di creare un modello di mail, aggiungendo semplicemente un'immagine ad un modello pre-esistente e decidere di registrarla come modello. Non l'avessi mai fatto... Mail si è incaxxxxo ed ora, come provo ad aprire l'icona modelli, mi salta mail.

Riavvii inutili.

Tengo a precisare che, visto che per lavoro, mi serviva di inviare sempre la stessa lettera con un'immagine, non è che ho modificato i modelli da html dentro Resources.

I passaggi che ho eseguito sono stati:

- aprire "mostra modelli"

- sceglierne uno

- aggiungere l'immagine .jpg

- registra come modello...

Infatti, la procedura è questa:

Posted Image

Ora a mio parere dovresti cercare di ricordare quale modello hai modificato.

Cercarlo con Pacifist nel DVD o nell'Installer (se indicassi quale sistema usi saprei dirtelo con sicurezza, non ho la palla di vetro) e sovrascrivere quello modificato.

Se non te lo ricordi fallo per l'intero blocco

Share this post


Link to post
Share on other sites

Ciao :)

allora, io ho un 10.5 e la versione di Mail è la 3.9.

Premesso che a me non compare l'immagine che mi hai allegato (a me ne appare una che spiega che, per eliminare i modelli devo aprire "mostra modelli" e fare clic su Rimuovi, ma... se non me li apre come faccio?), dovrei aver modificato il Butterfly (sono andato a vedere dentro mail e ho riconosciuto la farfalla ma, devo precisare che non c'è la minima traccia della mia modifica) ma, alla fine però, non ho modificato un modello ma ne ho registrato uno nuovo "registra come modello"

Share this post


Link to post
Share on other sites

ho cercato anche sulla libreria personale ma non trovo alcun documento nuovo. E dire che l'ho pure Nominato con un nome nuovo. Dove li va a salvare i nuovi modelli? Sto cercando ma... Mi parla di cartelle personali o personalizzate... bah :(

Share this post


Link to post
Share on other sites

Non so che dirti.

Non ho la possibilità di indagare perché la mia versione di Mail.app è un'altra e potrei indicarti la soluzione sbagliata.

Il consiglio dato mi sembra tuttora valido, quello di usare Pacifist.

Potresti provare prima a riparare le preferenze di Mail con PreferentialTreatment (fallo per tutta la cartella utente, male non fa)

Dopo, se non funziona, trascinare le preferenze sulla scrivania (Mail chiusa e poi riaprila), ma perdi impostazioni e devi ricompilarle.

Oppure, prima di operare con Pacifist, ma pronto a farlo, elimina semplicemente quel modello, se non ti servirà mai va bene così, in un prossimo aggiornamento lo riavrai.

Sono soluzioni dettate da mie impressioni, non soluzioni testate o trovate in altre parti.

Non credo troverei risposte in una ricerca, dato il caso piuttosto anomalo

Share this post


Link to post
Share on other sites

Io agirei in un altro modo, ma non posso consigliartelo, in quanto avendo due versioni differenti potrei sbagliare.

Se fossi in grado di farlo potresti usare questo sistema.

Aprire (ci sono più strumenti per farlo) ed editare il file di preferenze.

Ma, come detto, è una manovra esperta, più facile provare le soluzioni già indicate

Share this post


Link to post
Share on other sites

Per ora ti ringrazio. Scusa se non ti ho risposto prima ma mi è arrivata gente :)

Sto scaricando Preferential Treatment (del quale ignoravo l'esistenza :) ) e farò la prova con quello.

Cancellando le preferenze però, vuol dire perdere i filtri impostati, gli account, le cartelle... oddio mio, un incubo.

Proverò a vedere cosa mi dice il software indicato e, semmai, proverò con pacifist.

Secondo te quindi, se cancello il butterfly.mailstationary, dovrei cancellare anche il file che ho registrato come nuovo, anche se non lo vedo?

Share this post


Link to post
Share on other sites

... Secondo te quindi, se cancello il butterfly.mailstationary, dovrei cancellare anche il file che ho registrato come nuovo, anche se non lo vedo?

Io credo che non ci sia nessun file nuovo, solo quello originale corrotto.

Quando richiami la voce di menù che lo riguarda, Mail non lo riconosce, va in conflitto e il processo, per evitare altri guai, viene terminato

Share this post


Link to post
Share on other sites

Allora,

prova 1, uso di Preferential Treatment: sia sul lato utente che quello amministrativo, non ci sono problemi.

prova 2, eliminazione fisica di Butterfly.mailstationary e riavvio di mail ma, non ne vuol sapere.

Come premo il pulsante "mostra modelli" si chiude Mail.

Credo che sia Butterfly.mailstationary perché è quello che ho riconosciuto dalle foto che ci sono all'interno del pacchetto. Però, torno a ripetere, non ci sono modifiche di data :(

Quindi suppongo che il file che ho registrato non sia li dentro ma da un'altra parte.

Visto che sei stato così gentile, puoi fare una prova? Puoi aprire un modello, metterci dentro un'immagine qualsiasi e poi Registrare il Modello con Archivio --> Registra come Modello.

Tanto gli devi dare un nome e poi vedere dove piazza il file del nuovo modello...

Sempre se te la senti perché, se fa casino anche a te, mi dispiacerebbe essere il responsabile :(

Share this post


Link to post
Share on other sites

Ok, ho risolto... Nel senso che, almeno ora funziona mostra modelli.

Andando per tentativi, alla fine ho compresso la cartella Resources che si trova:

Libreria --> Application Support --> Apple-->Mail-->Stationery-->Apple-->contents-->Resources

Con mail chiuso ho cancellato i file originali e riavviato mail.

Ho riaperto "mostra Modelli" e mi deve solo l'immagine dell'icona (senza anteprima) e i nomi dei due file che avevo creato. Ne ho cancellato uno e mail si è chiuso. L'ho riaperto, ho cancellato l'altro e... MAIL non si è chiuso :)

ho decompresso il file Resouces e ho rimesso la cartella sotto la libreria e... zac... ora mail non salta e visualizza i modelli di base. Ovviamente quelli che avevo creato son scomparsi ma... non si può avere tutto dalla vita :)

Sicuramente i file dei modelli che avevo registrato erano da qualche parte con il .nomefile, invisibili, visto che non li vedevo con la ricerca.

OK, grazie comunque dell'aiuto.

A presto :)

ciao ciao

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this