Sign in to follow this  
macmanico

Spegnimento lento

Recommended Posts

Edit: ho corretto il post, visto la risposta in contemporanea.

--------------------------------------------------------------

Bene, per il problema dello spegnimento sto aspettando qualche avvenimento che faccia luce

Share this post


Link to post
Share on other sites

Edit: ho corretto il post, visto la risposta in contemporanea.

--------------------------------------------------------------

Bene, per il problema dello spegnimento sto aspettando qualche avvenimento che faccia luce

se posso essere utile con qualche test più intelligente del mio sono a disposizione.

tutto il resto che mi avevi consigliato di fare direi che l'ho fatto :confused:

Share this post


Link to post
Share on other sites

Ciao Faxus!!

Mi intrometto in questa discussione perché ho lo stesso problema ormai da tempo....

Sinceramente non è che mi interessa molto quanto ci impiega a spegnersi, ma mi da un po' fastidio il fatto che faccia sta cosa che non dovrebbe fare...

Stavo aspettando un aggiornamento da parte di apple, ma a quanto sembra tarda ad arrivare....

È la solita cosa, Apple cambia qualcosa del sistema in un aggiornamento.

Il cambiamento non va molto d'accordo con alcune applicazioni.

Non è detto che Apple sistemi il problema con un prossimo aggiornamento.

Più probabile che gli aggiornamenti di alcune applicazioni sistemino il problema.

In merito al fatto che questa anomalia sia dovuta ad applicazioni di terze parti mi sembra alquanto strano...ti spiego perché...

Io un imac e un mac mini e tutti e due hanno questo problema. Il fatto è che su ambedue i dispositivi ho installato ML pulito e inizialmente non ho installato alcun programma se non i soliti made in apple (iphoto, pages, numbers e simili....)

Poi sul imac ho installato diversi programmi ma sul mini (che uso solo come lettore di contenuti multimediali) oltre a quelli made in apple ho solo VLC, unarchiver, e flash....solo ieri ho installato anche java...

Quindi o è uno dei programmi tra VLC, unarchiver, e flash oppure uno dei programmi made in apple...oppure è un problema del sistema...

Sinceramente ho il dubbio che derivi da qualche connessione dalla quale ML fatica a sconnettersi durante lo spegnimento...che ne dici? potrebbe essere?

Share this post


Link to post
Share on other sites

Non so, Ponzo.

Le ipotesi sono molte, sono coinvolte notifiche fra applicazioni, gestione delle finestre e connessioni che non si chiudono.

Onestamente non riesco a trovare un filo, neanche sembra che qualcun altro riesca a farlo.

Metti pure che il problema non è grave (non c'è nessuna funzione pratica che viene negata, né si rilevano particolari rallentamenti nell'uso) e quindi non è prioritario.

Non è appassionante, neanche nella sua complessità, risolverlo sarebbe solo un esercizio di stile

Share this post


Link to post
Share on other sites

La risposta del mio collega sul suo MacMini di casa, praticamente quasi vergine in fatto di programmi e con ML installato pulito, sono 3 sec. killando prima appleeventsd e 15 in condizioni normali.

nel frattempo, a tempo perso, ravano la rete in cerca di ipotetiche soluzioni

See you soon...

Share this post


Link to post
Share on other sites

La cosa che mi fa pensare a un problema con le connessioni è questo "Invalid connection 47875" che si ripete in continuazione nei messaggi di console allo spegnimento...

Inoltre se il mac è acceso da poco e/o non ho alcuna connessione con nessun server e/o dispositivo, lo spegnimento mi risulta normalissimo

Ti posto i messaggi del mio spegnimento di ieri sera...

23/10/12 00:10:49,000 kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=502[GoogleSoftwareUp] clearing CS_VALID23/10/12 00:12:11,945 Dock[151]: Unable to open IOHIDSystem (e00002bd)23/10/12 00:12:11,000 kernel[0]: virtual bool IOHIDEventSystemUserClient::initWithTask(task_t, void *, UInt32): Client task not privileged to open IOHIDSystem for mapping memory (e00002c1)23/10/12 00:12:17,597 com.apple.launchd.peruser.501[139]: (com.apple.PackageKit.InstallStatus) Throttling respawn: Will start in 9 seconds23/10/12 00:12:17,752 WindowServer[97]: dict count after removing entry for window 0x29 is 023/10/12 00:12:17,867 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,867 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,868 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,868 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,868 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,868 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,868 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,869 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,869 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,869 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,869 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,918 coreservicesd[63]: SendFlattenedData, got error #268435459 (ipc/send) invalid destination port from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=14823/10/12 00:12:17,920 WindowServer[97]: kCGErrorIllegalArgument: CGXGetWindowWithName: Invalid key23/10/12 00:12:17,932 com.apple.launchd.peruser.501[139]: ([0x0-0x28028].com.apple.AppleSpell[282]) Exited: Killed: 923/10/12 00:12:17,933 com.apple.launchd.peruser.501[139]: ([0x0-0xf00f].com.apple.iTunesHelper[201]) Exited with code: 123/10/12 00:12:17,938 com.apple.launchd.peruser.501[139]: (com.apple.mdworker.shared.02000000-0000-0000-0000-000000000000[495]) Exited: Killed: 923/10/12 00:12:17,938 com.apple.launchd.peruser.501[139]: (com.apple.mdworker.single.08000000-0000-0000-0000-000000000000[503]) Exited: Killed: 923/10/12 00:12:17,941 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,941 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,941 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,941 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,942 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:17,943 coreservicesd[63]: SendFlattenedData, got error #268435460 (ipc/send) timed out from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=15223/10/12 00:12:17,944 coreservicesd[63]: SendFlattenedData, got error #268435460 (ipc/send) timed out from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=28923/10/12 00:12:17,982 loginwindow[43]: DEAD_PROCESS: 43 console23/10/12 00:12:18,269 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:18,269 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:18,270 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:18,270 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:18,270 WindowServer[97]: CGXGetConnectionProperty: Invalid connection 4787523/10/12 00:12:18,289 coreservicesd[63]: SendFlattenedData, got error #268435459 (ipc/send) invalid destination port from ::mach_msg(), sending notification kLSNotifyApplicationDeath to notificationID=13223/10/12 00:12:18,848 shutdown[514]: halt by rubenzanetti: 23/10/12 00:12:18,849 shutdown[514]: SHUTDOWN_TIME: 1350943938 84855123/10/12 00:12:18,919 UserEventAgent[11]: Captive: [UserAgentDied:139] User Agent @port=22279 Died23/10/12 00:12:19,059 blued[57]: -[CBManager init] init returning self:0x7fad5b62ccb023/10/12 19:17:03,000 bootlog[0]: BOOT_TIME 1351012623 0

Share this post


Link to post
Share on other sites

Mi sembra un'ottima intuizione, probabilmente hai colto nel segno.

Qualche esperienza e un po' di ricordi mi fanno pensare ad Apple che...

... che mette dentro qualcosa che ancora non ha implementato...

Share this post


Link to post
Share on other sites

udite, udite... mi viene da ridere... questa mattina il mio collega di cui sopra con il MacMini mi fa:

"a Giò... ti vuoi fare due risate?... da dopo la prova che mi hai fatto fare, il MacMini adesso mi si spegne in 2-3 secondi"

"CHE?!?!?!... ma Appleeventsd c'è sempre?"

"Si, SI... c'è sempre"

Ai posteri l'ardua sentenza... e io continuo a ravanare

see you soon...

Share this post


Link to post
Share on other sites

Mi infilo anche io nella discussione... Va detto, con l'avvento dell'SSD non spengo MAI il mio MacBook...

Però il 90% delle volte che lo spengo e/o riavvio ci mette più di 10 secondi!!!

Su Lion avevo degli shutdownStall, su ML mai successo...

Share this post


Link to post
Share on other sites

il problema persiste..dopo gli ultimi aggiornamenti tra cui safari, posto il check del mac, per capire se posso provare ad eliminare qualche plug-in o fare altri tentativi:

Hardware Information:

MacBook - model: MacBook6,1

1 2.26 GHz Intel Core 2 Duo CPU: 2 cores

2 GB RAM

System Software:

OS X 10.8.2 (12C60) - Uptime: 0 days 2:4

Disk Information:

Corsair Force 3 SSD disk0 : (120,03 GB)

disk0s1 (disk0s1) <not mounted>: 209,7 MB

SSD Force 3 (disk0s2) /: 119,17 GB (75,73 GB free)

Recovery HD (disk0s3) <not mounted>: 650 MB

MATSHITADVD-R UJ-898

USB Information:

Apple Inc. Built-in iSight

Apple Inc. Apple Internal Keyboard / Trackpad

Apple Inc. BRCM2070 Hub

Apple Inc. Bluetooth USB Host Controller

FireWire Information:

Kernel Extensions:

Problem System Launch Daemons:

[failed] com.apple.xprotectupdater.plist

Problem System Launch Agents:

[failed] com.apple.afpstat.plist

Launch Daemons:

[loaded] com.adobe.fpsaud.plist

[loaded] com.barebones.authd.plist

[loaded] com.microsoft.office.licensing.helper.plist

[loaded] com.noatime.root.plist

Launch Agents:

User Launch Agents:

User Login Items:

smcFanControl

3rd Party Preference Panes:

Flash Player

Flip4Mac WMV

Java

Internet Plug-ins:

AdobePDFViewer.plugin

Flash Player.plugin

FlashPlayer-10.6.plugin

Flip4Mac WMV Plugin.plugin

iPhotoPhotocast.plugin

JavaAppletPlugin.plugin

QuickTime Plugin.plugin

SharePointBrowserPlugin.plugin

Silverlight.plugin

User Internet Plug-ins:

Bad Fonts:

None

Top Processes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this