Gandalfrank

Aggiornamento a Maveticks: problema audio

Recommended Posts

Dopo avere aggiornato il mio Mac Book Pro 13" 8.1 da Lion  a Mavericks l'icona del volume risulta essere disabilitata.


Ciò non accade sempre; a volte è attiva altre no. Ma non sono riuscito a capire con quale criterio ciò accade.


 


Avete qualche consiglio su come risolvere?


Share this post


Link to post
Share on other sites

È sicuramente un comportamento anomalo che non ha una spiegazione con quel poco che leggo, pur se conclusivo.


 


Normalmente la cosa, se fosse stabile e a seconda dei casi e del funzionamento, richiederebbe il controllo dell'utilità MIDI Audio, un reset del SMC, reset della VRAM, una cancellazione delle preferenze dei menù extra.


Sempre a seconda dei casi, una delle manovre sopra risolverebbe, sia facendo un'analisi che eseguendole a caso fino a risoluzione.


 


Ma a mio parere dipende da un'applicazione di terze parti che interferisce.


 


Conosci meglio di me il tuo sistema, cerca di associare il comportamento alla situazione e vedi se riesci a capire quale è.


Puoi vedere nelle Preferenze di Sistema > Utenti e gruppi > elementi del login, libreria del disco > LaunchDaemon e Launch Agents, considera anche gli eventuali apparati collegati alla macchina all'accensione, come telefono, AppleTv ecc.


 


Se neanche questo fosse sufficiente, prova ad accedere al sistema in modalità sicura, verificando se continua il comportamento.


Se in questo modo risulta l'icona fissa e audio funzionante (a proposito: a parte l'icona-menulet, l'audio c'è? Ed è regolabile o no?), dovresti analizzare il system log all'avvio, che sicuramente ne porta traccia o cercare nelle estensioni del kernel di terze parti che possono essere critiche.


 


Se non riesci a trovare spiegazioni posta il system.log dall'avvio al caricamento delle estensioni e degli elementi del login e il risultato di quest'interrogazione:



kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'

Share this post


Link to post
Share on other sites

Grazie per la risposta, che vedo solo ora per pura casualità poiché non ho ricevuto nessuna notifica mail...


 


L'audio funziona SEMPRE ma :


1- è regolabile SE l'icona del volume è attiva


2- NON è regolabile SE l'icona del volume non è attiva.


 


Prima di postare la richiesta di aiuto avevo provato a resettare, senza soluzione, la VRAM.


 


Una cosa che ho dimenticato di scrivere è che sul portatile è presente in dual boot Windows 7, sul quale ovviamente, TUTTO funziona a dovere.


 


Farò le prove che mi hai indicato e ti farò sapere i risultati.


Share this post


Link to post
Share on other sites

Ho risolto.


Un programma, perfettamente funzionante in Lion, non viene eseguito correttamente in Mavericks chiudendosi automaticamente e generando un log. Si tratta di un applicazione proprietaria della Sitecom che trasforma il router wifi X4 N300 in una print server


L'ho disinstallato e tutto è tornato a posto.


Share this post


Link to post
Share on other sites

Dopo avere aggiornato il mio Mac Book Pro 13" 8.1 da Lion  a Mavericks l'icona del volume risulta essere disabilitata.

Ciò non accade sempre; a volte è attiva altre no. Ma non sono riuscito a capire con quale criterio ciò accade.

 

Avete qualche consiglio su come risolvere?

Ciao, è successo anche a me dopo aver installato mavericks, ho risolto facendo un reset della pram, premendo all'avvio dopo il tasto di accensione cmd+alt+p+r contemporaneamente. Al contrario di come c'è scritto sul sito della apple, ho dovuto tenere premuta la combinazione di tasti fino al 3 suono del mac...facendo solo 2 suoni il problema non si è risolto....

spero di essere stato utile.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now