Peppuccio Ravidà

Problema parizione Mac!

Recommended Posts

Salve ragazzi, preso dalla curiosità ho deciso di installare la beta di yosemite. Per fare ciò ho creato una partizione sul mio SSD da 256 GB di 55GB dove poi ho installato Yosemite. Adesso vorrei nuovamente ridare tutta la memoria al mio sistema normale ed eliminare quindi questa parte con Yosemite però qui sorge il problema. Praticamente le icone sono grigie quelle "+" e "-" presenti in Utility Disco e soprattutto, il mio SSD Principale che prima mi segnava 256 GB con sotto poi "Macintosh HD" adesso mi segna 55 GB e si chiama Yosemite e sotto di esso vi sono le due partizioni Macintosh HD e Yosemite. Che cavolo devo fare? xD


post-49868-0-90960300-1408761666_thumb.p


Share this post


Link to post
Share on other sites

Se avvii con alt che dischi d'avvio vedi disponibili?


 


Apri Terminale, digita diskutil list e copia/incolla qui il responso eliminando le righe superflue coi dati personali.


 


42 6.gif


Share this post


Link to post
Share on other sites

Con Alt vedo il disco d'avvio Macintosh HD e quello Yosemite. Ecco qui:


   #:                       TYPE NAME                    SIZE       IDENTIFIER


   0:      GUID_partition_scheme                        *251.0 GB   disk0


   1:                        EFI EFI                     209.7 MB   disk0s1


   2:                  Apple_HFS Macintosh HD            194.2 GB   disk0s2


   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3


   4:          Apple_CoreStorage                         55.3 GB    disk0s4


   5:                 Apple_Boot Recovery HD             650.0 MB   disk0s5


/dev/disk1


   #:                       TYPE NAME                    SIZE       IDENTIFIER


   0:                  Apple_HFS Yosemite               *54.6 GB    disk1


Share this post


Link to post
Share on other sites

/dev/disk0

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *251.0 GB   disk0

   1:                        EFI EFI                     209.7 MB   disk0s1

   2:                  Apple_HFS Macintosh HD            194.2 GB   disk0s2

   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

   4:          Apple_CoreStorage                         55.3 GB    disk0s4

   5:                 Apple_Boot Recovery HD             650.0 MB   disk0s5

/dev/disk1

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:                  Apple_HFS Yosemite               *54.6 GB    disk1

 

Le partizioni vecchie ci sono e quindi dovrebbe bastare una stringa da Terminale per cancellare il disco virtuale Apple_CoreStorage, che ora è l'unico visibile ed accessibile, o per ripristinare la situazione originale. Purtroppo sono in ferie col vecchio portatile e non sono in grado di testarne l'efficacia, per cui passo la mano a qualcuno che si sente sicuro nel darti indicazioni.

 

 

P.S. ti ho mandato un Messaggio Personale.

Share this post


Link to post
Share on other sites

Ho risolto il problema, praticamente era un cosa semplicissima. Nella mia partizione Yosemite avevo attivato il File Vault che mi ha codificato la partizione per proteggerla, disattivando il file Vault ho tolto la codifica e così potevo eliminare la partizione e fare tutto quello che dovevo fare :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now