454734

Problema installazione Windows Bootcamp

Recommended Posts

Ho un MBP 13" Mid 2012, a cui la settimana scorsa ho tolto il superdrive per inserire un SSD.


La configurazione attuale consiste in un ssd da 128 gb nel bay nativo (il disco che ho fatto mettere quando comprai il mac) e un secondo ssd da 240 gb nell'optibay.


L'idea - coerente con il mio modo di lavorare e le mie necessità - era di avere l'ssd da 240 in dual boot Mac+Win e lasciare il vecchio da 128 per i dati e con una partizione exfat d'interscambio.


 


Stamattina ho avviato bootcamp, creato la usb di boot con la .iso di Win7, partizionato 50 gb e avviato il tutto. la procedura di installazione procede correttamente fino a che non mi è possibile installare windows nella partizione bootcamp. L'errore è il 0x80300024. In ogni caso un messaggio di avviso mi avverte ancora prima che io vada a confermare la procedura di installazione nella partizione selezionata.


Ho provato dall'installer di windows a riformattare la partizione (ntfs automaticamente) ma non cambia nulla. ho fermato il tutto e provato a formattare in ntfs da utility disco del mac e poi fare il reboot da chiavetta, ma arrivati a quel punto stesso problema. Ho controllato anche le altre partizioni ma il messaggio di avviso di cui parlo sopra compare in tutte, quindi non credo sia un problema legato alla partizione specifica.


Ho cercato ovunque ma ho trovato soltanto indicazioni confuse e problematiche differenti. C'è chi dice che è un problema dovuto al fatto che quando windows rileva più di un disco impazzisce e suggerisce di rimuovere temporaneamente il disco di avvio di osx e lasciare solo quello windows, oppure di scambiare i collegamenti sata (ma io non ho intenzione di smontare il mac e togliere dischi, anche perchè la partizione bootcamp è sul disco d'avvio di osx) ci sono altri che dicono sia un problema di guid, che per windows si può provare con mbr, ma anche in questo caso non posso aver una partizione guid per mac e una mbr per win. Ho anche letto qualcosa a proposito della modalità di avvio efi della chiavetta (ma su questo argomento sono impreparato...), che non sarebbe compatibile con la tabella guid. Suggeriscono di eliminare i file che portano al boot in modalità efi dalla chiavetta, ho provato a combinare qualcosa...ma nulla.


Il disco nuovo da 240gb che sto utilizzando viene rilevato dal mac come disk1, mentre quello originale che però adesso è solo un disco dati viene etichettato disk0. Anche in questo caso leggevo di qualcuno che suggeriva di provare a installare win sul disk 0, ma il disk 1 è correttamente impostato come disco d'avvio, quindi non capisco il problema...


 


Francamente non so davvero che fare, aiuto!


Share this post


Link to post
Share on other sites

Quello che sono riuscito a capire fin'ora, raccimolando informazioni frammentarie quà e là e unendole con la mia poca competenza, è che:


- La partizione Windows è correntemente formattata in NTFS.


- Il disco di avvio è in GPT e non credo ci sia modo di avere una partizione GPT (per Mac) e una MBR (per Win) sullo stesso disco.


- Bootcamp imposta la chiavetta perchè avvii Windows in EFI e non in BIOS.


- L'avvio in EFI non comporta problemi su partizioni GUID.


- Con Bootcamp è supportato solo l'avvio in BIOS mode???


...mi sono perso!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now