da filemaker 2 a 7


Recommended Posts

ho alcuni vecchi documenti filemaker pro 2 che non riesco ad aprire con filemaker pro 7, dice di usare la versione 2. Ma quella andava solo con il vecchio sistema. Ora che faccio? Possibile non sia in grado di importare le versioni precedenti?

Link to comment
Share on other sites

Beh... è da dire che un database creato con FileMaker 2 può essere aperto dalle versioni che girano solo sotto i vecchi System, perciò da FM Pro 3, 4 e 5.

Ho cominciato con FileMaker Pro 2 (che non so più dove ho ficcato i floppy...) e sono arrivato alla 8 Advanced, per cui, tutti i lavori fatti con la 2 li ho subito convertiti a partire dalla versione 3, la prima a creare database relazionali (la 2 non era "relazionale"), tant'è che un database creato con FMPro 3 è facilmente convertibile con FMPro 8 (fatto a gennaio e riprovato 10' fa). Poi vi è da dire che dalla versione 7 i database creati sono significativamente diversi dai precedenti: con le versioni dalla 3 alla 6 ogni tabella corrispondeva ad un file mentre dalla 7 un file può contenere innumerevoli tabelle ...

Come puoi ben capire il problema è apparentemente irrisolvibile. Sull'iMac G5 ho ancora tutti i vecchi FileMaker a partire dalla 4 per cui potrei convertire i tuoi file cosicché da poterli aprire con FM Pro 7 (meglio la 8 anche se i file mantengono il suffisso .fp7)

Comunque ecco cosa dice FileMaker (soprattutto la 5)

In FileMaker Pro 5:

"..........

4.3 In Mac OS, FileMaker Pro 5 è in grado di convertire i file creati con qualunque versione di FileMaker Pro. Per aprire con FileMaker Pro 5 per Windows i database creati in Mac OS con FileMaker Pro 1.0, occorre convertirli in Mac OS tramite una versione successiva di FileMaker Pro. Per eseguire la conversione, è possibile scaricare una versione di prova di FileMaker Pro per Mac OS dal sito www.filemaker.com."

Tutto qua.

Fammi sapere e sai una connessione veloce mandameli che te li "traduco".

Ciao

Link to comment
Share on other sites

Grazie per le informazioni!

Ho scoperto che c'è la versione 6.0 che gira su X e che è l'ultima in grado di tradurre i FMP 2.x. Dato che è possibile scaricare la versione Trial qui ( http://filemaker.custhelp.com/cgi-bin/filemaker.cfg/php/enduser/std_adp.php?p_faqid=750&p_created=1115172465&p_sid=tinO314i&p_lva=&p_sp=cF9zcmNoPSZwX3NvcnRfYnk9JnBfZ3JpZHNvcnQ9JnBfcm93X2NudD00MDEyJnBfcHJvZHM9JnBfY2F0cz0mcF9wdj0mcF9jdj0mcF9wYWdlPTE*&p_li=&p_topview=1 ) sono riuscito a tradurre i vecchi documenti.

Ora li ho aggiornati in FMP 7 ed ora nuovo pasticcio: mi chiede, oltre alla PW, anche il nome utente: di cosa? Nella versione precedente non c'era. Se lascio in bianco, non lo accetta, se metto solo la PW neppure. Mah!

Link to comment
Share on other sites

Ora li ho aggiornati in FMP 7 ed ora nuovo pasticcio: mi chiede, oltre alla PW, anche il nome utente: di cosa? Nella versione precedente non c'era. Se lascio in bianco, non lo accetta, se metto solo la PW neppure. Mah!

Ho trovato la soluzione: apro il documento nella versione 6, tolgo la password, aggiorno il documento alla versione 7. Altrimenti non c'è verso di aprirlo. :confused:

Link to comment
Share on other sites

Ottimo! Comunque, se lo scherzo continua con la 7, come Nome utente metti Admin e la password la lasci stare. Di solito me la apre. Una volta aperto, vai al menù File, selezioni Opzioni file... Lì selezioni "Accedi usando:" e clicca su Nome utente; nel campo sottostante (Nome utente) scrivi Admin, il campo Password lo lasci stare. Dai OK ed il file non ti darà più noie.

:)

Ciao

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share