Sign in to follow this  
Ratman10

Due iMac G3 che non partono: può essere la batteria?

Recommended Posts

Io l'ultima l'ho trovata in un ottimo negozio di elettronica (in provincia di Torino) che si occupa anche di antifurti ed è molto fornito per quanto riguarda le batterie di telecomandi ed affini. Il prezzo è stato di 6,50€.

Ripensandoci, lunedì proverò in un negozio del genere piuttosto fornito che purtroppo nei giorni scorsi era chiuso per inventario.

P.S. Les collines, sous l'avion, creusaient déjà leur sillage d'ombre dans l'or du soir.

Frequento da molti anni diversi forum con lo stesso nick e ti assicuro che è la prima volta che qualcuno fa un commento consono (normalmente la reazione tipica è "voldecosa?") ;):)

Share this post


Link to post
Share on other sites

Bene, sono riuscito a trovare le batterie ;) , sono ben cariche, ma purtroppo entrambi gli iMac continuano a non dare segni di vita.

Ho seguito attentamente le istruzioni riportate nel manuale: sostituzione della batteria e reset della PRAM con l'alimentazione staccata, quindi stessa procedura ma con il cavo collegato.

Poi ho misurato la tensione nei pressi della batteria e del processore grafico con i seguenti risultati:

1. iMac n.1: tensione nei pressi della batteria, 4,96 V (5 V valore indicato nel manuale); tensione accanto al processore grafico, -1,3V (-1,2V indicato nel manuale).

2. iMac n.2: tensione nei pressi della batteria, 4,92 V (5 V valore indicato nel manuale); tensione accanto al processore grafico, -1,23V (-1,2V indicato nel manuale).

Penso che i valori siano corretti o sbaglio? Questo deovrebbe indicare, sempre seguendo le istruzioni, che la scheda di alimentazione ed analogica del video funziona, ma la cosa non mi convince.

In sostanza, stando così le cose, il manuale consiglia di sostituire la scheda del pulsante di accensione (uhmm... ) e se ancora non va di "sostiruire il monitor (riuhmmm...). Insomma, la scheda logica non viene neanche menzionata, il che mi sembra molto strano.

Infine, quando si preme il pulsante d'accensione, la tensione dovrebbe passare a 20V, questa tensione è fornita dalla "down power board", la scheda di alimentazione direttamente collegata alla scheda logica? O e sempre la scheda di alimentazione collegata al CRT a variare la tensione?

Share this post


Link to post
Share on other sites

Bene, sono riuscito a trovare le batterie ;) , sono ben cariche, ma purtroppo entrambi gli iMac continuano a non dare segni di vita.

Prova ad insistere e tienili attaccati un bel po' alla tensione di rete

1. iMac n.1: tensione nei pressi della batteria, 4,96 V (5 V valore indicato nel manuale); tensione accanto al processore grafico, -1,3V (-1,2V indicato nel manuale).

2. iMac n.2: tensione nei pressi della batteria, 4,92 V (5 V valore indicato nel manuale); tensione accanto al processore grafico, -1,23V (-1,2V indicato nel manuale).

Perfette.

L'alimentazione è corretta, ma sta di fatto che il calcolatore non parte. A dire la verità, mia madre mi ha detto per telefono che è morto anche il mio...

In sostanza, stando così le cose, il manuale consiglia di sostituire la scheda del pulsante di accensione (uhmm... ) e se ancora non va di "sostiruire il monitor (riuhmmm...). Insomma, la scheda logica non viene neanche menzionata, il che mi sembra molto strano.

Non tanto; è più facile che si rompa qualcosa sulla scheda analogica che sulla scheda analogica.

Infine, quando si preme il pulsante d'accensione, la tensione dovrebbe passare a 20V, questa tensione è fornita dalla "down power board", la scheda di alimentazione direttamente collegata alla scheda logica? O e sempre la scheda di alimentazione collegata al CRT a variare la tensione?

Da quello che mi ricordo, nella scheda analogica si trova la prima parte di un convertitore a commutazione. Sulla scheda analogica arrivano 24V alternati (ad alta frequenza), i quali vengono portati direttamente sulla schedina di conversione che si occupa di ricavare tutte le tensioni necessarie all'alimentazione della macchina. Mi pare pero' che i 5V necessari allo startup vengono ricavati da un circuito separato sulla scheda analogica (mi pare di aver visto un 7805 da qualche parte). Non mi ricordo se i 24V sono presenti sempre (mi pare), oppure se l'accensione avviene sulla scheda analogica. Esiste pero' un segnale di diagnostica della scheda analogica: se viene segnalato un problema, la scheda logica non fa partire la macchina; forse l'avevo cortocircuitato durante i miei tentativi (ehm, non che sia una cosa elegante e che consiglierei di fare)...

Avevo trovato una pagina utile per le piedinature:

http://www.hardmac.com/articles/39/page3

Share this post


Link to post
Share on other sites

A dire la verità, mia madre mi ha detto per telefono che è morto anche il mio...

Mannaggia... :confused: Tienimi aggiornato ;)

Avevo trovato una pagina utile per le piedinature:

http://www.hardmac.com/articles/39/page3

Ottime informazioni, anche se avrò bisogno di un po' di calma per capire bene tutti i cablaggi e le relative tensioni :)

In ogni caso, questa mattina prima di uscire l'ho attaccato alla corrente, vediamo se ha bisogno di un po' di tempo; se così fosse, potrebbe essere qualche condensatore un po' "fiacco".

Share this post


Link to post
Share on other sites

Caspita, ho fatto una ricerca su google ed è pieno di iMac inseriti in nuovi case (scatole, vecchi videoregistratori... di tutto) per via di problemi all'alimentazione... Ho anche chiamato a casa e, dopo una mattinata di alimentazione continua, continuano a non avviarsi.

Perciò, sono ormai quasi convinto che sia proprio un problema alla power board. Come dicevo all'inizio, se si pensa all'intera sostituzione è il guasto peggiore che possa capitare all'iMac (con il CRT...); tuttavia, non è possibile provare ad effettuare una riparazione? D'altronde le schede di alimentazione sono le unicche parti che non utilizzano il surface mount...

Share this post


Link to post
Share on other sites

Certo che si puo' pensare di riparare una scheda analogica. Il problema è semmai che è montata in modo che è scomodo lavorarci sopra e che non vedo vie agevoli per identificare il guasto, in mancanza di informazioni più dettagliate sulla scheda (che ne so, un abbozzo di schema elettrico).

E' la ragione per cui consigliavo di rivolgersi ad un riparatore TV che faccia questo lavoro per passione, dato che puo' essere pericoloso mettere le mani in circuiti del genere senza avere esperienza.

Share this post


Link to post
Share on other sites

Cercando in giro, sembrerebbe che il problema principale sia il trasformatore flyback; su Macbidouille e altri siti c'è chi ha sostituito questo pezzo, pittosto economico, e ha visto risorgere il proprio iMac. Tuttavia quando il trasformatore, per via di polvere e calore, va in corto, c'è il rischio che venga danneggiato qualcosa anche sulla scheda analogica; infatti molti altri lo hanno sostituito senza risolvere il problema...

Potrei superare la paura di mettere le mani su componenti potenzialmente pericolosi, utilizzando tutte le precauzioni necessarie (guanti da elettricista, CRT scaricato, occhiali protettivi...) e gli strumenti adeguati. Non avrei nulla in contrario, allo stesso tempo, a far effettuare la riparazione ad un tecnico. In entrambi i casi, però, credo che come hai sottolineato, l'assenza di uno schema elettrico sia un problema insormontabile.

Per ora, quindi, mi dedicherò per un po' soltanto al googling...

Share this post


Link to post
Share on other sites

Ragazzi..ieri ho aggiornato il mio imac g3 ad osx (c'era il system 9): tutto ok!

Oggi l'ho smontato ed ho sostituito la so-dimm (presente vicino al processore) con una più capiente (ma di diversa frequenza: 66 mhz la mia, mentre quella originale dovrebbe essere 100).

Monto, riavvio.. il mac è partito ma poco prima della fine dell'avvio di osx si è piantato tutto! Ho lasciato premuto il tasto di alimentazione ma nulla.. cosi ho dovuto staccare la spina.

Ora non parte più! Anche rimettendo la sua Ram originale non va.

Che può essere? alimentatore? Pulsantino di avvio?

batteria?

help meeee!!! :( :(

Share this post


Link to post
Share on other sites

Cercando in giro, sembrerebbe che il problema principale sia il trasformatore flyback; su Macbidouille e altri siti c'è chi ha sostituito questo pezzo, pittosto economico, e ha visto risorgere il proprio iMac. Tuttavia quando il trasformatore, per via di polvere e calore, va in corto, c'è il rischio che venga danneggiato qualcosa anche sulla scheda analogica; infatti molti altri lo hanno sostituito senza risolvere il problema...

Potrei superare la paura di mettere le mani su componenti potenzialmente pericolosi, utilizzando tutte le precauzioni necessarie (guanti da elettricista, CRT scaricato, occhiali protettivi...) e gli strumenti adeguati. Non avrei nulla in contrario, allo stesso tempo, a far effettuare la riparazione ad un tecnico. In entrambi i casi, però, credo che come hai sottolineato, l'assenza di uno schema elettrico sia un problema insormontabile.

Riprendo questa discussione dopo un anno, nel caso in cui possa essere utile a qualcuno, ed eventualmente a Vol de nuit, se è ancora in ascolto.

Il guasto del mio iMac G3 (che si manifestava con l'impossibilità di avviarlo) era dovuto ai condensatori elettrolitici della scheda analogica che erano andati.

In particolare, uno da 33µF montato per stabilizzare la linea B+ era in pessimo stato ed aveva rilasciato l'elettrolita sullo stampato. Non avevo visto il problema subito, perché la carcassa del condensatore era apparentemente integra e mascherava il disastro. Me ne sono accorto notando che il calcolatore partiva se riscaldavo una certa parte della scheda con un phon e controllando successivamente con un misuratore di ESR.

Cambiati i condensatori, il problema è stato risolto completamente.

Guasti del genere sono frequenti, perché ho idea che la temperatura in alcuni punti della scheda sia piuttosto alta dopo qualche ora di utilizzo.

Resta inteso che lavorare attorno al collo del tubo catodico richiede attenzione.

Share this post


Link to post
Share on other sites

Credo di avere proprio il problema che tu hai risolto, ma non so nè come è fatto un condensatore ne dove si trova. Puoi aiutarmi, e magari dirmi se è cosa che poso fare da me o e bene che mi rivolga ad un elettricista? Sei la mia unica speranza prima di buttare il computer

Share this post


Link to post
Share on other sites

Credo di avere proprio il problema che tu hai risolto, ma non so nè come è fatto un condensatore ne dove si trova. Puoi aiutarmi, e magari dirmi se è cosa che poso fare da me o e bene che mi rivolga ad un elettricista? Sei la mia unica speranza prima di buttare il computer

Lavorare attorno al collo del tubo catodico può essere pericoloso se non si sa dove mettere le mani. In particolare, il tubo può implodere sparando pezzi di vetro dappertutto. Dovrebbero esserci delle protezioni interne al tubo, ma è sempre meglio non fare la prova.

Per quanto riguarda la riparazione, la macchina è molto complessa da smontare ed in particolare lo è la scheda analogica. La sostituzione dei condensatori elettrolitici (ammesso che il problema venga da lì, cosa tutta da verificare) è un'operazione tranquillamente alla portata di un buon riparatore TV che però abbia tempo da perdere.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this