Recommended Posts

  • Replies 3.6k
  • Created
  • Last Reply

Top Posters In This Topic

Ciò che mi preoccupa è proprio l'impossibilità di "collegarsi" con il modem (via ping, via browser/indirizzo IP, terminale...); come è possibile scoprire se c'è qualche problema hardware?

Link to post
Share on other sites

Su questo non so aiutarti perchè perché finora ho sempre lavorato con dei routers, mai con un modem adsl.

Comunque in linea di principio se il modem ha un indirizzo ip deve essere pingabile.

Se non ho capito male l'indirizzo del modem è 10.0.0.138. Ma la maschera di rete?

Qual'è l'indirizzo del Mac? Appartiene alla stessa classe di indirizzi?

Link to post
Share on other sites

In casa ho una piccola rete con PowerMac G4, iMac G3 e Powerbook Pismo collegati con lo switch che vedi in un'immagine più sopra.

I computer si vedono via AppleTalk o con indirizzo IP (se con MacOS X) di classe diversa (192.x.x.x), l'indirizzo del modem é quello di fabbrica (10.0.0.138 appunto).

Non capisco perché non riesca a entrare nel "setup" del modem: il manuale dice semplicemente di lanciare un browser e inserire l'indirizzo IP per impostare i parametri, tra cui lo stesso indirizzo IP (c'era una notizia su macity qualche mese fa).

Mi dite, per favore, come fare fisicamente il collegamento? Premesso che lo switch deve rimanere, il modem lo collego alla porta Uplink con cavo incrociato (tentativo già fatto ma il led sulla porta ethernet del modem non si accendeva) o ad una porta normale con cavo dritto? Ora, come già scritto, il modem é collegato con cavo dritto alla porta uplink (evidentemente non settata come uplink ma come porta "normale").

Credo di aver provato tutte le combinazioni di cavi e porte e quella attuale é l'unica con cui si accende il led (posteriore) sul modem; però sono dispostissimo a rifare tutto... problemi di linea permettendo.

Link to post
Share on other sites

Prova ad assegnare ad uno dei mac un indirizzo ip del tipo 10.0.0.x e vedi se riesci a fare ping sul modem.

Se funziona dovrebbe andare anche il setup via browser.

A questo punto o il setup ti permette di cambiare l'ip del modem in 192.x.y.z oppure devi cambiare gli ip della tua rete casalinga in 10.0.0.x/255.255.255.0

Link to post
Share on other sites

<FONT COLOR="ff0000">Ping avviato ...

PING 10.0.0.138 (10.0.0.138): 56 data bytes

64 bytes from 10.0.0.138: icmp_seq=0 ttl=255 time=2.654 ms

64 bytes from 10.0.0.138: icmp_seq=1 ttl=255 time=1.245 ms

64 bytes from 10.0.0.138: icmp_seq=2 ttl=255 time=1.262 ms

64 bytes from 10.0.0.138: icmp_seq=3 ttl=255 time=6.186 ms

64 bytes from 10.0.0.138: icmp_seq=4 ttl=255 time=1.237 ms

64 bytes from 10.0.0.138: icmp_seq=5 ttl=255 time=1.995 ms

64 bytes from 10.0.0.138: icmp_seq=6 ttl=255 time=5.439 ms

64 bytes from 10.0.0.138: icmp_seq=7 ttl=255 time=1.588 ms

64 bytes from 10.0.0.138: icmp_seq=8 ttl=255 time=1.256 ms

64 bytes from 10.0.0.138: icmp_seq=9 ttl=255 time=6.918 ms

--- 10.0.0.138 ping statistics ---

10 packets transmitted, 10 packets received, 0% packet loss

round-trip min/avg/max = 1.237/2.978/6.918 ms</FONT>

et voilà! Grazie Andrea!

E' bastato mettere un computer su indirizzo 10.0.0.x per entrare nel setup del modem...

ho aggiunto un indirizzo del tipo 192.x.y.z e adesso dal browser si accede sia con l'indirizzo di default che con quello nuovo...

Il problema è quindi la linea... Posted ImagePosted ImagePosted Image

Franco> i cavi sono integri, li ho usati solo in casa e trattati sempre con riguardo... ora funziona tutto (beh, connessione a parte) anche con il cavo originale del modem!

Grazie, vi farò sapere.

Link to post
Share on other sites

Attenzione non è detto che sia la linea!

Potrebbe ancora essere un problema di indirizzi ip:

Se gli indirizzi dei Mac della rete sono ancora 192.x.y.z (devi usare 192.168.x.y per essere corretti) non puoi uscire in internet senza un router che connetta la rete 192... a quella 10......

La soluzione più semplice è dunque quella di assegnare a tutti i Mac, indirizzi della rete 10.0.0.x oppure cambiare l'indirizzo del modem.

Altrimenti si può installare gRoute che attiva le capacità di routing di MacOSX, ma la soluzione è meno conveniente. Comunque se voui ti posso dare maggiori dettagli.

Link to post
Share on other sites

Sì, grazie Andrea, te ne sarei grato.

Io ho aggiunto un indirizzo 192.168.X.Y alla configurazione del modem; infatti con impostazioni di rete 192.168.X.Y ora accedo al setup sia con indirizzo della stessa classe che con quello di default.

Aggiungerò una configurazione di classe 10.0.0.X ai computer in rete.

Infine sto valutando seriamente l'acquisto di un router ADSL tipo quello farallon recensito da Macity un mesetto fa oppure un Belkin (che avevo trovato a 150 € due settimane fa, mentre adesso costa 200 €, stesso fornitore...). L'aggeggio risolverebbe tantissimi problemi... compresa la condivisione dell'accesso a internet!

Ora però devo far funzionare il tutto con accesso singolo...

Ciao.

Link to post
Share on other sites