Sign in to follow this  
stephen

Gira una versione di Tiger per PC??

Recommended Posts

Ora non vorrei andare OffTopic ... però io me li sono appena scaricati gli Xcode 2.1

Ora non dovrebbe essere sufficiente sbarrare la benedetta casellina? Apro Xcode, scelgo un progetto Cocoa Application, lo compilo "normalmente" e tutto fila liscio, se barro la casellina per x86 mi fallisce per questo motivo:

Xcode

Non sono uno sviluppatore ma non penso che sia proprio così semplice!!!

Sicuramente bisognerà adattare a mano qualche stringa per via che sia compatibile con ambedue le piattaforme. O Sbaglio :confused:

Share this post


Link to post
Share on other sites
Guest gennaro_mac

No scusa non ci siamo capiti. Apri Xcode e selezioni il template per una nuova applicazione. Ti crea il modello e compili solo quello. Se in un progetto come Mathematica per OS X si cambiano solo 20 righe ....

Share this post


Link to post
Share on other sites
Guest gennaro_mac

shinjixp ok provo a riformulare la domanda ... poi magari la sposto in un altro thread:

Ho installato Xcode 2.1, questo mi deve permettere di compilare per x86 ... quando compilo il template prefatto di un'applicazione cocoa non document based non mi compila se spuntol 'opzione di generare il codice x86. Installazione di Tiger a fresco, installazione di Xcode 2.1 a fresco. Qualcuno c'ha provato e mi sa dire perché non mi compila? Mi ripeto non sto parlando di una mia app, ma semplicemente del template prefatto.

Share this post


Link to post
Share on other sites
Guest gennaro_mac

Ho provato anche con uno standard tool in C

#include <stdio.h>

int main(int argc, const char * argv[]) {

printf("\nHello world!\n");

return 0;

}

Non compila manco questo ... stesso errore :-/ ed il codice mi pare abbastanza portabile :-P

Share this post


Link to post
Share on other sites
Guest gennaro_mac

No, l'installazione degli Xcode gliel'ho fatta fare completa :-/ comunque ora apro un thread apposta

Share this post


Link to post
Share on other sites

> hanno lanciato l'Xcode 2.1, con le caselline da barrare se si vuole programmare per PPC e per Intel...lui ha detto di barrarle entrambe

dimmi la verita': tu sei uno sviluppatore, vero?

>la versione che hanno gli sviluppatori è praticamente una base su cui programmi di terze parti non girerebbero

perche'?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this