Intel «La vulnerabilità dei processori riguarda tutti i costruttori», AMD nega

Meltdown e Spectre

Intel non è l’unico costruttore colpito dal bug nei processori individuato in tutte le CPU prodotte negli ultimi 10 anni. Il costruttore di Santa Clara dichiara che la vulnerabilità dei processori interessa diversi dispositivi, vendor e sistemi operativi, ma AMD smentisce

Dopo la diffusione della notizia di bug all’interno dei processori Intel che riguardano tutte le CPU prodotte negli ultimi dieci anni, Intel ha diramato un comunicato per spiegare che, a suo dire, questi exploit non consentono potenzialmente di “corrompere, modificare o cancellare dati”.

«Recenti segnalazioni riferiscono che questi exploit sono causati da “bug” o “falle” e sono una caratteristica propria dei prodotti Intel» si legge nel comunicato. L’azienda ad ogni modo nega che il problema riguardi solo Intel e secondo le loro analisi fin qui eseguite il problema riguarda “molti tipi di dispositivi, molti differenti vendor di processori e sistemi operativi”, tutti suscettibili in egual modo all’inconveniente.

“Intel è impegnata nella produzione e nella sicurezza dei clienti e sta lavorando a stretto contatto con molte altre aziende IT, incluse AMD, ARM Holdings e molti vendor di sistemi operativi per sviluppare un approccio industriale per risolvere il problema in maniera tempestiva e costruttiva”. L’azienda spiega che ha fornito aggiornamenti software e firmware per mitigare il problema degli exploit e che “contrariamente a quanto indicato da alcuni report, qualsiasi impatto in termini di performance è dipendente dal carico di lavoro e – per l’utilizzatore medio di computer – non dovrebbero essere significativo e sarà mitigato con il passare del tempo”.

Intel consiglia di verificare la disponibilità di aggiornamenti del sistema operativo per il proprio sistema e installarli prima possibile, ribadisce che i suoi prodotti “sono i più sicuri al mondo” e che con il supporto dei suoi partner le attuali soluzioni al problema consentono di offrire il miglior approccio possibile in termini di sicurezza utente.

vulnerabilità dei processori - FOTO Intel Core i7

Nel frattempo ricercatori di sicurezza hanno evidenziato la presenza di due differenti vulnerabilità che riguardano sia i processori Intel, sia quelli di ARM. Denominate Meltdown e Spectre, le vulnerabilità potrebbero offrire a cybercriminali accesso ai dati in memoria di app in esecuzione e quindi password, email, documenti, foto e così via.

Stando a quanto dichiarato dai ricercatori a ZDNet, qualunque sistema prodotto dal 1995 in poi è potenzialmente a rischio. “Meltdown” è in grado di leggere l’intera memoria fisica di un sistema target. L’attacco, conosciuto anche come KPTI o KAISER, aggira l’isolamento fondamentale tra le applicazioni d’utente e il sistema operativo e consente ad un programma di accedere alla memoria di altri programmi e del sistema operativo.La falla in questione riguarda solo i processori Intel e può essere risolta con un update che potrebbe rallentare il sistema operativo in generale.

Spectre” è una falla che interessa tutti i processori, inclusi quelli con architettura ARM. Questa consente di aggirare l’isolamento tra diverse applicazioni e permette a un attacker di accedere ai dati in memoria di altre applicazioni. È più complicata da sfruttare ma al momento non sono noti possibili fix. Secondo i ricercatori richiederebbe addirittura di ripensare e riprogettare l’architettura di alcuni processori.

Non è chiaro se le vulnerabilità Meltdown e Spectre siano state già sfruttate, ma sul web sono già apparsi esempi di prove concettuali. AMD ha invece preso la palla al balzo per evidenziare che dalle analisi fin qui eseguite i suoi prodotti non presentano i problemi in questione. ARM ha confermato di stare lavorando con Intel e AMD per cercare una soluzione comune al problema.

Gli sviluppatori dei sistemi operativi più importanti hanno tutti già integrato patch specifiche per le vulnerabilità individuate nei processori Intel. Apple ha integrato meccanismi di difesa nell’aggiornamento di macOS 10.13.2.